DNN (DotNetNuke) 9.2 <= 9.2.2 弱式加密演算法弱點

high Nessus Plugin ID 154728

Synopsis

遠端 Web 伺服器含有一個受到弱式加密演算法弱點影響的 ASP.NET 應用程式。

描述

遠端主機上執行的 DNN Platform (之前稱為 DotNetNuke) 版本為 9.2 至 9.2.2 ,使用弱式加密演算法來保護輸入參數。

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 DNN Platform 9.3.1 或更新版本。

另請參閱

https://www.dnnsoftware.com/community/security/security-center

Plugin 詳細資訊

嚴重性: High

ID: 154728

檔案名稱: dotnetnuke_9_3_1_weak_encryption.nasl

版本: 1.6

類型: remote

系列: CGI abuses

已發布: 2021/10/29

已更新: 2022/4/11

風險資訊

CVSS 評分資料來源: CVE-2018-18325

VPR

風險因素: Medium

分數: 5.1

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 4.3

媒介: AV:N/AC:L/Au:N/C:P/I:N/A:N

時間媒介: E:H/RL:OF/RC:C

CVSS v3

風險因素: High

基本分數: 7.5

時間分數: 7.2

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

時間媒介: E:H/RL:O/RC:C

弱點資訊

CPE: cpe:/a:dotnetnuke:dotnetnuke

必要的 KB 項目: installed_sw/DNN

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2019/4/3

弱點發布日期: 2019/7/3

CISA 已知利用日期: 2022/5/3

惡意利用途徑

Metasploit (DotNetNuke Cookie Deserialization Remote Code Excecution)

參考資訊

CVE: CVE-2018-15811, CVE-2018-18325