NewStart CGSL CORE 5.04 / MAIN 5.04:libldb 弱點 (NS-SA-2021-0106)

high Nessus Plugin ID 154617

語系:

Synopsis

遠端 NewStart CGSL 主機受到一個弱點影響。

描述

執行 CORE 5.04 / MAIN 5.04 版的遠端 NewStart CGSL 主機上安裝的 libldb 套件受到一個弱點影響:

- 在 Samba 的 libldb 中發現一個瑕疵。LDAP 屬性中的多個連續前置空格可導致超出邊界記憶體寫入,進而導致處理要求的 LDAP 伺服器處理程序損毀。此弱點對系統可用性威脅最大。(CVE-2021-20277)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級易受弱點影響的 CGSL libldb 套件。請注意,可能尚未出爐已升級的套件。如需詳細資訊,請聯絡 ZTE。

另請參閱

http://security.gd-linux.com/notice/NS-SA-2021-0106

http://security.gd-linux.com/info/CVE-2021-20277

Plugin 詳細資訊

嚴重性: High

ID: 154617

檔案名稱: newstart_cgsl_NS-SA-2021-0106_libldb.nasl

版本: 1.2

類型: local

已發布: 2021/10/28

已更新: 2021/10/28

風險資訊

VPR

風險因素: Low

分數: 3.6

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 3.7

媒介: AV:N/AC:L/Au:N/C:N/I:N/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2021-20277

CVSS v3

風險因素: High

基本分數: 7.5

時間分數: 6.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:zte:cgsl_core:ldb-tools, p-cpe:/a:zte:cgsl_core:libldb, p-cpe:/a:zte:cgsl_core:libldb-debuginfo, p-cpe:/a:zte:cgsl_core:libldb-devel, p-cpe:/a:zte:cgsl_core:pyldb, p-cpe:/a:zte:cgsl_core:pyldb-devel, p-cpe:/a:zte:cgsl_main:ldb-tools, p-cpe:/a:zte:cgsl_main:libldb, p-cpe:/a:zte:cgsl_main:libldb-debuginfo, p-cpe:/a:zte:cgsl_main:libldb-devel, p-cpe:/a:zte:cgsl_main:pyldb, p-cpe:/a:zte:cgsl_main:pyldb-devel, cpe:/o:zte:cgsl_core:5, cpe:/o:zte:cgsl_main:5

必要的 KB 項目: Host/local_checks_enabled, Host/ZTE-CGSL/release, Host/ZTE-CGSL/rpm-list, Host/cpu

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2021/9/24

弱點發布日期: 2021/3/24

參考資訊

CVE: CVE-2021-20277

IAVA: 2021-A-0140-S