NewStart CGSL CORE 5.05 / MAIN 5.05:libxml2 多個弱點 (NS-SA-2021-0148)

high Nessus Plugin ID 154604

語系:

Synopsis

遠端 NewStart CGSL 主機受到多個弱點影響。

描述

執行 CORE 5.05 / MAIN 5.05 版的遠端 NewStart CGSL 主機上安裝的 libxml2 套件受到多個弱點影響:

- 在 libxml2 2.9.10 之前版本中,parser.c 的 xmlParseBalancedChunkMemoryRecover 會發生與 newDoc-> oldNs 相關的記憶體洩漏。(CVE-2019-19956)

- 在 libxml2 2.9.10 版中,xmlschemas.c 的 xmlSchemaPreRun 允許發生 xmlSchemaValidateStream 記憶體洩漏情形。
(CVE-2019-20388)

- 在 libxml2 2.9.10 中,parser.c 的 xmlStringLenDecodeEntities 在特定檔案結尾狀況中存在無限迴圈問題。(CVE-2020-7595)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級易受攻擊的 CGSL libxml2 套件。請注意,可能尚未出爐已升級的套件。如需詳細資訊,請聯絡 ZTE。

另請參閱

http://security.gd-linux.com/notice/NS-SA-2021-0148

http://security.gd-linux.com/info/CVE-2019-19956

http://security.gd-linux.com/info/CVE-2019-20388

http://security.gd-linux.com/info/CVE-2020-7595

Plugin 詳細資訊

嚴重性: High

ID: 154604

檔案名稱: newstart_cgsl_NS-SA-2021-0148_libxml2.nasl

版本: 1.2

類型: local

已發布: 2021/10/28

已更新: 2021/10/28

風險資訊

VPR

風險因素: Medium

分數: 4.4

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 3.7

媒介: AV:N/AC:L/Au:N/C:N/I:N/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2020-7595

CVSS v3

風險因素: High

基本分數: 7.5

時間分數: 6.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:zte:cgsl_core:libxml2, p-cpe:/a:zte:cgsl_core:libxml2-devel, p-cpe:/a:zte:cgsl_core:libxml2-python, p-cpe:/a:zte:cgsl_core:libxml2-static, p-cpe:/a:zte:cgsl_main:libxml2, p-cpe:/a:zte:cgsl_main:libxml2-devel, p-cpe:/a:zte:cgsl_main:libxml2-python, p-cpe:/a:zte:cgsl_main:libxml2-static, cpe:/o:zte:cgsl_core:5, cpe:/o:zte:cgsl_main:5

必要的 KB 項目: Host/local_checks_enabled, Host/ZTE-CGSL/release, Host/ZTE-CGSL/rpm-list, Host/cpu

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2021/9/24

弱點發布日期: 2019/12/24

參考資訊

CVE: CVE-2019-19956, CVE-2019-20388, CVE-2020-7595

IAVA: 2020-A-0326