PHP 7.4.x < 7.4.25

high Nessus Plugin ID 154349

Synopsis

遠端 Web 伺服器上執行的 PHP 版本受到一個弱點影響。

描述

遠端主機上安裝的 PHP 版本為 7.4.25 之前的版本。因此,其會受到版本 7.4.25 公告中所提及的一個弱點影響。

- 在 PHP 7.3.x 之前的版本 (包含 7.3.31)、7.4.25 之前的 7.4.x 和 8.0.12 之前的 8.0.x 版本中,當主 FPM 程序處理程序以 root 身分執行、子工作處理程序以權限較的使用者身分執行,則執行 PHP FPM SAPI 時,子處理程序可存取與主處理程序共用的記憶體、對其寫入內容,並透過可導致 root 處理程序執行無效的記憶體讀取和寫入的方式修改記憶體,進而將無權限的本機使用者權限提升至 root 使用者。
(CVE-2021-21703)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 PHP 7.4.25 版或更新版本。

另請參閱

http://bugs.php.net/81026

http://php.net/ChangeLog-7.php#7.4.25

Plugin 詳細資訊

嚴重性: High

ID: 154349

檔案名稱: php_7_4_25.nasl

版本: 1.8

類型: remote

系列: CGI abuses

已發布: 2021/10/22

已更新: 2022/4/11

風險資訊

CVSS 評分資料來源: CVE-2021-21703

VPR

風險因素: High

分數: 7.4

CVSS v2

風險因素: Medium

基本分數: 6.9

時間分數: 5.1

媒介: AV:L/AC:M/Au:N/C:C/I:C/A:C

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: High

基本分數: 7

時間分數: 6.1

媒介: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP, installed_sw/PHP

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2021/10/21

弱點發布日期: 2021/10/21

參考資訊

CVE: CVE-2021-21703

IAVA: 2021-A-0503