Oracle Primavera Gateway (2021 年 10 月 CPU)

high Nessus Plugin ID 154297

Synopsis

遠端主機受到多個弱點影響

描述

遠端主機上安裝的 Primavera Gateway 版本受到 2021 年 10 月 CPU 公告中提及的多個弱點影響,包括:

- Oracle Retail 應用程式的 Oracle Retail Store Inventory Management 產品中存在的弱點 (元件:SIM 整合 (JDBC))。受影響的支援版本是 14.1、15.0 和 16.0。
攻擊此弱點有一定的難度,具有網路存取權的未經驗證攻擊者可藉此弱點透過 Oracle Net 入侵 Oracle Retail Store Inventory Management。若要成功攻擊,必須有攻擊者以外之他人的互動,且雖然弱點位於 Oracle Retail Store Inventory Management 中,但攻擊可能對其他產品造成重大影響。若成功攻擊此弱點,攻擊者可以接管 Oracle Retail Store Inventory Management。(CVE-2021-2351)

- Oracle Construction and Engineering 的 Primavera Unifier 產品中的弱點 (元件:檔案管理 (Apache Commons Compress))。受影響的支援版本是 17.7-17.12、18.8、19.12 和 20.12。攻擊此弱點的難度較小,經由 HTTP 存取網路的未經驗證攻擊者可藉此入侵 Primavera Unifier。若成功攻擊此弱點,可能導致攻擊者在未經授權的情況下,造成 Primavera Unifier 懸置或經常重複性當機 (完全 DOS)。(CVE-2021-36090)

- Oracle Construction and Engineering 的 Primavera Unifier 產品中的弱點 (元件:
Platform、UI (Lodash))。受影響的支援版本是 17.7-17.12、18.8、19.12 和 20.12。攻擊此弱點的難度較小,經由 HTTP 存取網路的高權限攻擊者可藉此入侵 Primavera Unifier。(CVE-2021-23337)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

按照 2021 年 10 月 Oracle 重要修補程式更新公告,套用適當的修補程式。

另請參閱

https://www.oracle.com/a/tech/docs/cpuoct2021cvrf.xml

https://www.oracle.com/security-alerts/cpuoct2021.html

Plugin 詳細資訊

嚴重性: High

ID: 154297

檔案名稱: oracle_primavera_gateway_cpu_oct_2021.nasl

版本: 1.5

類型: remote

系列: CGI abuses

已發布: 2021/10/21

已更新: 2022/5/9

風險資訊

CVSS 評分資料來源: CVE-2021-23337

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: Medium

基本分數: 6.5

時間分數: 5.7

媒介: AV:N/AC:L/Au:S/C:P/I:P/A:P

時間媒介: E:H/RL:OF/RC:C

CVSS v3

風險因素: High

基本分數: 7.5

時間分數: 7.2

媒介: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

時間媒介: E:H/RL:O/RC:C

弱點資訊

CPE: cpe:/a:oracle:primavera_gateway

必要的 KB 項目: installed_sw/Oracle Primavera Gateway

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2021/10/19

弱點發布日期: 2021/10/19

參考資訊

CVE: CVE-2021-2351, CVE-2021-23337, CVE-2021-29425, CVE-2021-36090, CVE-2021-36374

IAVA: 2021-A-0480