Oracle Linux 8:java-1.8.0-openjdk (ELSA-2021-3893)

medium Nessus Plugin ID 154269

概要

遠端 Oracle Linux 主機缺少一個或多個安全性更新。

說明

遠端 Oracle Linux 8 主機中安裝的套件受到 ELSA-2021-3893 公告中提及的多個弱點影響。

- Oracle Java SE 的 Java SE、Oracle GraalVM 企業版產品中存在弱點 (元件:
JSSE)。受影響的支援版本是 Java SE:7u311、8u301、11.0.12;Oracle GraalVM 企業版:20.3.3 和 21.2.0。難以利用的弱點允許具有網路存取權的未經驗證攻擊者透過 TLS 入侵 Java SE、Oracle GraalVM 企業版。若成功攻擊此弱點,未經授權即可存取重要資料,或完整存取所有可供存取的 Java SE、Oracle GraalVM 企業版資料。注意:此弱點適用於 Java 部署,通常是在執行沙箱 Java Web Start 應用程式或沙箱 Java Applet 的用戶端中,這種部署會載入並執行不受信任的程式碼 (例如,來自網際網路的程式碼),並依賴 Java 沙箱獲得安全性。使用指定之元件中的 API 也可以惡意利用此弱點,例如,透過提供資料給 API 的 Web 服務。CVSS 3.1 Base Score 5.9 (機密性影響)。CVSS 向量:(CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N)。(CVE-2021-35550)

- Oracle Java SE 的 Java SE、Oracle GraalVM 企業版產品中存在弱點 (元件:
Swing)。受影響的支援版本是 Java SE:7u311、8u301、11.0.12、17;Oracle GraalVM 企業版:20.3.3 和 21.2.0。此弱點較易攻擊成功,能夠透過多個通訊協定存取網路的未經驗證攻擊者可藉此入侵 Java SE、Oracle GraalVM 企業版。
若成功攻擊此弱點,則可能導致在未經授權的情況下造成 Java SE、Oracle GraalVM 企業版部分拒絕服務 (部分 DOS)。注意:此弱點適用於 Java 部署,通常是在執行沙箱 Java Web Start 應用程式或沙箱 Java Applet 的用戶端中,這種部署會載入並執行不受信任的程式碼 (例如,來自網際網路的程式碼),並依賴 Java 沙箱獲得安全性。此弱點不適用於僅載入並執行受信任程式碼 (例如,系統管理員安裝的程式碼) 的 Java 部署,通常是在伺服器中。CVSS 3.1 Base Score 5.3 (可用性影響)。CVSS 向量:(CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L)。(CVE-2021-35556)

- Oracle Java SE 的 Java SE、Oracle GraalVM 企業版產品中存在弱點 (元件:
Swing)。受影響的支援版本是 Java SE:7u311、8u301、11.0.12、17;Oracle GraalVM 企業版:20.3.3 和 21.2.0。此弱點較易攻擊成功,能夠透過多個通訊協定存取網路的未經驗證攻擊者可藉此入侵 Java SE、Oracle GraalVM 企業版。
若成功攻擊此弱點,則可能導致在未經授權的情況下造成 Java SE、Oracle GraalVM 企業版部分拒絕服務 (部分 DOS)。注意:此弱點適用於 Java 部署,通常是在執行沙箱 Java Web Start 應用程式或沙箱 Java Applet 的用戶端中,這種部署會載入並執行不受信任的程式碼 (例如,來自網際網路的程式碼),並依賴 Java 沙箱獲得安全性。使用指定之元件中的 API 也可以惡意利用此弱點,例如,透過提供資料給 API 的 Web 服務。CVSS 3.1 Base Score 5.3 (可用性影響)。CVSS 向量:(CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L)。(CVE-2021-35559)

- Oracle Java SE 的 Java SE、Oracle GraalVM 企業版產品中存在弱點 (元件:
Libraries)。受影響的支援版本是 Java SE:8u301、11.0.12、17;Oracle GraalVM 企業版:20.3.3 和 21.2.0。此弱點較易攻擊成功,能夠透過 Kerberos 存取網路的低權限攻擊者可藉此入侵 Java SE、Oracle GraalVM 企業版。若要成功攻擊,必須有除攻擊者以外的他人互動,雖然此弱點位於 Java SE、Oracle GraalVM 企業版中,但攻擊可能對其他產品造成重大影響。
若成功攻擊此弱點,未經授權即可存取重要資料,或完整存取所有可供存取的 Java SE、Oracle GraalVM 企業版資料。注意:此弱點適用於 Java 部署,通常是在執行沙箱 Java Web Start 應用程式或沙箱 Java Applet 的用戶端中,這種部署會載入並執行不受信任的程式碼 (例如,來自網際網路的程式碼),並依賴 Java 沙箱獲得安全性。使用指定之元件中的 API 也可以惡意利用此弱點,例如,透過提供資料給 API 的 Web 服務。CVSS 3.1 Base Score 6.8 (機密性影響)。CVSS 向量:(CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N)。(CVE-2021-35567)

- Oracle Java SE 的 Java SE、Oracle GraalVM 企業版產品中存在弱點 (元件:
JSSE)。受影響的支援版本是 Java SE:8u301、11.0.12、17;Oracle GraalVM 企業版:20.3.3 和 21.2.0。此弱點較易攻擊成功,能夠透過 TLS 存取網路的未經驗證攻擊者可藉此入侵 Java SE、Oracle GraalVM 企業版。若成功攻擊此弱點,則可能導致在未經授權的情況下造成 Java SE、Oracle GraalVM 企業版部分拒絕服務 (部分 DOS)。注意:此弱點僅可透過以下方式遭到惡意利用:提供資料給指定元件中的 API,而不使用未受信任的 Java Web Start 應用程式或是未受信任的 Java Applet,如透過 Web 服務。CVSS 3.1 Base Score 5.3 (可用性影響)。CVSS 向量:
(CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L)。(CVE-2021-35578)

- Oracle Java SE 的 Java SE、Oracle GraalVM 企業版產品中存在弱點 (元件:
ImageIO)。受影響的支援版本是 Java SE:7u311、8u301、11.0.12、17;Oracle GraalVM 企業版:20.3.3 和 21.2.0。此弱點較易攻擊成功,能夠透過多個通訊協定存取網路的未經驗證攻擊者可藉此入侵 Java SE、Oracle GraalVM 企業版。
若成功攻擊此弱點,則可能導致在未經授權的情況下造成 Java SE、Oracle GraalVM 企業版部分拒絕服務 (部分 DOS)。注意:此弱點適用於 Java 部署,通常是在執行沙箱 Java Web Start 應用程式或沙箱 Java Applet 的用戶端中,這種部署會載入並執行不受信任的程式碼 (例如,來自網際網路的程式碼),並依賴 Java 沙箱獲得安全性。使用指定之元件中的 API 也可以惡意利用此弱點,例如,透過提供資料給 API 的 Web 服務。CVSS 3.1 Base Score 5.3 (可用性影響)。CVSS 向量:(CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L)。(CVE-2021-35586)

- Oracle Java SE 的 Java SE、Oracle GraalVM 企業版產品中存在弱點 (元件:
Hotspot)。受影響的支援版本是 Java SE:7u311、8u301;Oracle GraalVM 企業版:20.3.3 和 21.2.0。難以惡意利用的弱點允許具有網路存取權的未經驗證攻擊者透過多個通訊協定入侵 Java SE、Oracle GraalVM 企業版。若要成功攻擊,必須有攻擊者以外之他人的互動。若成功攻擊此弱點,則可能導致在未經授權的情況下造成 Java SE、Oracle GraalVM 企業版部分拒絕服務 (部分 DOS)。注意:此弱點適用於 Java 部署,通常是在執行沙箱 Java Web Start 應用程式或沙箱 Java Applet 的用戶端中,這種部署會載入並執行不受信任的程式碼 (例如,來自網際網路的程式碼),並依賴 Java 沙箱獲得安全性。使用指定之元件中的 API 也可以惡意利用此弱點,例如,透過提供資料給 API 的 Web 服務。CVSS 3.1 Base Score 3.1 (可用性影響)。CVSS 向量:(CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:L)。(CVE-2021-35588)

- Oracle Java SE 的 Java SE、Oracle GraalVM 企業版產品中存在弱點 (元件:
JSSE)。受影響的支援版本是 Java SE:7u311、8u301、11.0.12、17;Oracle GraalVM 企業版:20.3.3 和 21.2.0。難以利用的弱點允許具有網路存取權的未經驗證攻擊者透過 TLS 入侵 Java SE、Oracle GraalVM 企業版。若成功攻擊此弱點,則可能導致在未經授權的情況下讀取部分 Java SE、Oracle GraalVM 企業版可存取資料。注意:此弱點適用於 Java 部署,通常是在執行沙箱 Java Web Start 應用程式或沙箱 Java Applet 的用戶端中,這種部署會載入並執行不受信任的程式碼 (例如,來自網際網路的程式碼),並依賴 Java 沙箱獲得安全性。使用指定之元件中的 API 也可以惡意利用此弱點,例如,透過提供資料給 API 的 Web 服務。CVSS 3.1 Base Score 3.7 (機密性影響)。CVSS 向量:
(CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N)。(CVE-2021-35603)

- Oracle Java SE 的 Java SE、Oracle GraalVM 企業版產品中存在弱點 (元件:
Utility)。受影響的支援版本是 Java SE:7u311、8u301、11.0.12、17;Oracle GraalVM 企業版:20.3.3 和 21.2.0。此弱點較易攻擊成功,能夠透過多個通訊協定存取網路的未經驗證攻擊者可藉此入侵 Java SE、Oracle GraalVM 企業版。
若成功攻擊此弱點,則可能導致在未經授權的情況下造成 Java SE、Oracle GraalVM 企業版部分拒絕服務 (部分 DOS)。注意:此弱點適用於 Java 部署,通常是在執行沙箱 Java Web Start 應用程式或沙箱 Java Applet 的用戶端中,這種部署會載入並執行不受信任的程式碼 (例如,來自網際網路的程式碼),並依賴 Java 沙箱獲得安全性。使用指定之元件中的 API 也可以惡意利用此弱點,例如,透過提供資料給 API 的 Web 服務。CVSS 3.1 Base Score 5.3 (可用性影響)。CVSS 向量:(CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L)。(CVE-2021-35561)

- Oracle Java SE 的 Java SE、Oracle GraalVM 企業版產品中存在弱點 (元件:
Keytool)。受影響的支援版本是 Java SE:7u311、8u301、11.0.12、17;Oracle GraalVM 企業版:20.3.3 和 21.2.0。此弱點較易攻擊成功,能夠透過多個通訊協定存取網路的未經驗證攻擊者可藉此入侵 Java SE、Oracle GraalVM 企業版。
若成功攻擊此弱點,則可能導致在未經授權的情況下更新、插入或刪除部分 Java SE、Oracle GraalVM 企業版可存取資料。注意:此弱點適用於 Java 部署,通常是在執行沙箱 Java Web Start 應用程式或沙箱 Java Applet 的用戶端中,這種部署會載入並執行不受信任的程式碼 (例如,來自網際網路的程式碼),並依賴 Java 沙箱獲得安全性。使用指定之元件中的 API 也可以惡意利用此弱點,例如,透過提供資料給 API 的 Web 服務。CVSS 3.1 Base Score 5.3 (完整性影響)。
CVSS 向量:(CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N)。(CVE-2021-35564)

- Oracle Java SE 的 Java SE、Oracle GraalVM 企業版產品中存在弱點 (元件:
JSSE)。受影響的支援版本是 Java SE:7u311、8u301、11.0.12;Oracle GraalVM 企業版:20.3.3 和 21.2.0。此弱點較易攻擊成功,能夠透過 TLS 存取網路的未經驗證攻擊者可藉此入侵 Java SE、Oracle GraalVM 企業版。若成功攻擊此弱點,則可能導致在未經授權的情況下造成 Java SE、Oracle GraalVM 企業版部分拒絕服務 (部分 DOS)。注意:此弱點僅可透過以下方式遭到惡意利用:提供資料給指定元件中的 API,而不使用未受信任的 Java Web Start 應用程式或是未受信任的 Java Applet,如透過 Web 服務。CVSS 3.1 Base Score 5.3 (可用性影響)。CVSS 向量:
(CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L)。(CVE-2021-35565)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

更新受影響的套件。

另請參閱

https://linux.oracle.com/errata/ELSA-2021-3893.html

Plugin 詳細資訊

嚴重性: Medium

ID: 154269

檔案名稱: oraclelinux_ELSA-2021-3893.nasl

版本: 1.4

類型: local

代理程式: unix

已發布: 2021/10/20

已更新: 2022/5/9

支援的感應器: Frictionless Assessment Agent, Nessus Agent, Nessus

風險資訊

VPR

風險因素: Medium

分數: 4.4

CVSS v2

風險因素: High

基本分數: 7.1

時間分數: 5.3

媒介: CVSS2#AV:N/AC:M/Au:N/C:C/I:N/A:N

CVSS 評分資料來源: CVE-2021-35550

CVSS v3

風險因素: Medium

基本分數: 6.8

時間分數: 5.9

媒介: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N

時間媒介: CVSS:3.0/E:U/RL:O/RC:C

CVSS 評分資料來源: CVE-2021-35567

弱點資訊

CPE: p-cpe:/a:oracle:linux:java-1.8.0-openjdk-src, p-cpe:/a:oracle:linux:java-1.8.0-openjdk-accessibility, p-cpe:/a:oracle:linux:java-1.8.0-openjdk-javadoc-zip, cpe:/o:oracle:linux:8, p-cpe:/a:oracle:linux:java-1.8.0-openjdk-accessibility-slowdebug, p-cpe:/a:oracle:linux:java-1.8.0-openjdk-devel, p-cpe:/a:oracle:linux:java-1.8.0-openjdk-headless-fastdebug, p-cpe:/a:oracle:linux:java-1.8.0-openjdk-javadoc, p-cpe:/a:oracle:linux:java-1.8.0-openjdk, p-cpe:/a:oracle:linux:java-1.8.0-openjdk-accessibility-fastdebug, p-cpe:/a:oracle:linux:java-1.8.0-openjdk-demo, p-cpe:/a:oracle:linux:java-1.8.0-openjdk-headless, p-cpe:/a:oracle:linux:java-1.8.0-openjdk-src-slowdebug, p-cpe:/a:oracle:linux:java-1.8.0-openjdk-fastdebug, p-cpe:/a:oracle:linux:java-1.8.0-openjdk-devel-fastdebug, p-cpe:/a:oracle:linux:java-1.8.0-openjdk-src-fastdebug, p-cpe:/a:oracle:linux:java-1.8.0-openjdk-headless-slowdebug, p-cpe:/a:oracle:linux:java-1.8.0-openjdk-demo-slowdebug, p-cpe:/a:oracle:linux:java-1.8.0-openjdk-slowdebug, p-cpe:/a:oracle:linux:java-1.8.0-openjdk-devel-slowdebug, p-cpe:/a:oracle:linux:java-1.8.0-openjdk-demo-fastdebug

必要的 KB 項目: Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list, Host/local_checks_enabled

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2021/10/20

弱點發布日期: 2021/10/19

參考資訊

CVE: CVE-2021-35550, CVE-2021-35556, CVE-2021-35559, CVE-2021-35561, CVE-2021-35564, CVE-2021-35565, CVE-2021-35567, CVE-2021-35578, CVE-2021-35586, CVE-2021-35588, CVE-2021-35603