Oracle MySQL Enterprise Monitor (2021 年 10 月 CPU)

high Nessus Plugin ID 154267

Synopsis

遠端主機受到多個弱點影響

描述

遠端主機上安裝的 MySQL Enterprise Monitor 8.0.25 版本受到 2021 年 10 月 CPU 公告中提及的多個弱點影響。

- Oracle MySQL 的 MySQL Enterprise Monitor 產品中存在的弱點 (元件:Monitoring: General (Spring Security))。受到影響的支援版本是 8.0.25 和之前的版本。具有網路存取權的低權限攻擊者可利用易受利用的弱點,透過 HTTPS 入侵 MySQL Enterprise Monitor。若攻擊成功,攻擊者可以接管 MySQL Enterprise Monitor。(CVE-2021-22112)

- Oracle Retail 應用程式的 Oracle Retail Predictive Application Server 產品中存在的弱點 (元件:RPAS Fusion 用戶端 (Spring Framework))。受影響的支援版本是 14.1.3、15.0.3 和 16.0.3。攻擊此弱點的難度較小,低權限攻擊者可藉此登入執行 Oracle Retail Predictive Application Server 的基礎結構,入侵 Oracle Retail Predictive Application Server。若攻擊成功,攻擊者可接管 Oracle Retail Predictive Application Server。(CVE-2021-22118)

- Oracle MySQL 的 MySQL Workbench 產品中存在的弱點 (元件:MySQL Workbench (OpenSSL))。
受到影響的支援版本是 8.0.26 和之前的版本。攻擊此弱點有一定難度,經由 MySQL Workbench 存取網路的未經驗證攻擊者可藉此入侵 MySQL Workbench。若成功攻擊此弱點,可導致攻擊者未經授權地存取重要資料或完整存取所有可供存取之 MySQL Workbench 資料,以及未經授權造成 MySQL Workbench 懸置或經常重複性當機 (完全 DOS)。(CVE-2021-3712)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

按照 2021 年 10 月 Oracle 重要修補程式更新公告,套用適當的修補程式。

另請參閱

https://www.oracle.com/a/tech/docs/cpuoct2021cvrf.xml

https://www.oracle.com/security-alerts/cpuoct2021.html

Plugin 詳細資訊

嚴重性: High

ID: 154267

檔案名稱: mysql_enterprise_monitor_8_0_27.nasl

版本: 1.3

類型: combined

系列: CGI abuses

已發布: 2021/10/20

已更新: 2021/10/21

風險資訊

CVSS 評分資料來源: CVE-2021-22112

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: High

基本分數: 9

時間分數: 7.8

媒介: AV:N/AC:L/Au:S/C:C/I:C/A:C

時間媒介: E:H/RL:OF/RC:C

CVSS v3

風險因素: High

基本分數: 8.8

時間分數: 8.4

媒介: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:H/RL:O/RC:C

弱點資訊

CPE: cpe:/a:oracle:mysql_enterprise_monitor

必要的 KB 項目: installed_sw/MySQL Enterprise Monitor

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2021/10/19

弱點發布日期: 2021/10/19

參考資訊

CVE: CVE-2021-3712, CVE-2021-22112, CVE-2021-22118, CVE-2021-29425, CVE-2021-33037