Apache 2.4.49 < 2.4.50 多個弱點

high Nessus Plugin ID 153884

Synopsis

遠端 Web 伺服器受到多個弱點影響。

描述

遠端主機上安裝的 Apache httpd 版本為 2.4.49。因此,會受到 2.4.50 公告中所提及的多個弱點影響。

- 模糊測試 2.4.49 httpd 時,在處理 HTTP/2 要求期間偵測到新的 NULL 指標解除參照,進而允許外部來源在伺服器上引致 DoS。這需要使用特製要求。此弱點是近期在 2.4.49 版本中引入的。該專案沒有發生已知的惡意利用。
(CVE-2021-41524)

- 在對 Apache HTTP Server 2.4.49 中的路徑標準化所做的變更中發現一個缺陷。攻擊者可利用路徑遍歷攻擊,將 URL 對應至預期文件 root 之外的檔案。如果文件 root 之外的檔案不受強制要求保護,則所有已拒絕的要求都可能會成功。此外,此缺陷可洩漏已解譯檔案 (如 CGI 指令碼) 的來源。已知此問題正被廣泛利用。此問題只會影響 Apache 2.4.49 ,不會影響其之前的版本。(CVE-2021-41773)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 Apache 2.4.50 或更新版本。

另請參閱

https://httpd.apache.org/security/vulnerabilities_24.html

Plugin 詳細資訊

嚴重性: High

ID: 153884

檔案名稱: apache_2_4_50.nasl

版本: 1.15

類型: combined

代理程式: windows, macosx, unix

系列: Web Servers

已發布: 2021/10/5

已更新: 2022/12/5

組態: 啟用徹底檢查

支持的傳感器: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

風險資訊

VPR

風險因素: Medium

分數: 6.9

CVSS v2

風險因素: Medium

基本分數: 4.3

時間分數: 3.7

媒介: AV:N/AC:M/Au:N/C:P/I:N/A:N

時間媒介: E:H/RL:OF/RC:C

CVSS 評分資料來源: CVE-2021-41773

CVSS v3

風險因素: High

基本分數: 7.5

時間分數: 7.2

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

時間媒介: E:H/RL:O/RC:C

弱點資訊

CPE: cpe:/a:apache:http_server, cpe:/a:apache:httpd

必要的 KB 項目: installed_sw/Apache

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2021/10/4

弱點發布日期: 2021/10/4

CISA 已知利用日期: 2021/11/17

惡意利用途徑

CANVAS (CANVAS)

Metasploit (Apache 2.4.49/2.4.50 Traversal RCE)

參考資訊

CVE: CVE-2021-41524, CVE-2021-41773

IAVA: 2021-A-0451-S

CEA-ID: CEA-2021-0046