Apache >= 2.4.30 < 2.4.49 mod_proxy_uwsgi

high Nessus Plugin ID 153586

Synopsis

遠端 Web 伺服器受到某個弱點影響。

描述

遠端主機上安裝的 Apache httpd 版本高於 2.4.30 但低於 2.4.49。因此受到 2.4.49 變更記錄中所提及的一個弱點影響。特製的要求 uri-path 可造成 mod_proxy_uwsgi 在所配置的記憶體之外讀取資料並造成當機 (DoS)。

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 Apache 2.4.49 或更新版本。

另請參閱

https://downloads.apache.org/httpd/CHANGES_2.4

https://httpd.apache.org/security/vulnerabilities_24.html

Plugin 詳細資訊

嚴重性: High

ID: 153586

檔案名稱: apache_mod_proxy_uwsgi_2_4_49.nasl

版本: 1.6

類型: combined

代理程式: windows, macosx, unix

系列: Web Servers

已發布: 2021/9/23

已更新: 2022/4/11

組態: 啟用徹底檢查

支持的傳感器: Nessus Agent

風險資訊

VPR

風險因素: Medium

分數: 5.1

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 3.7

媒介: AV:N/AC:L/Au:N/C:N/I:N/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2021-36160

CVSS v3

風險因素: High

基本分數: 7.5

時間分數: 6.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:apache:httpd, cpe:/a:apache:http_server

必要的 KB 項目: installed_sw/Apache

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2021/9/16

弱點發布日期: 2021/9/16

參考資訊

CVE: CVE-2021-36160

IAVA: 2021-A-0440-S