Apache Tomcat 10.0.0-M1 < 10.0.2 多個弱點

high Nessus Plugin ID 150856

Synopsis

遠端 Apache Tomcat 伺服器受到多個弱點影響

描述

遠端主機上安裝的 Tomcat 版本比 10.0.2 舊。因此,會受到 fixed_in_apache_tomcat_10.0.2_security-10 公告中所提及的多個弱點影響。

- 使用 Apache Tomcat 10.0.0-M1 至 10.0.0-M4 版本、9.0.0.M1 至 9.0.34 版、8.5.0 至 8.5.54 版以及 7.0.0 至 7.0.103 版時,如果 a) 攻擊者能夠控制伺服器上某個檔案的內容和名稱; 以及 b) 伺服器設定為使用具有 FileStore 的 PersistenceManager;以及 c) PersistenceManager 設定為 sessionAttributeValueClassNameFilter ='null' (除非使用 SecurityManager,否則為預設值) 或充分寬鬆的篩選條件,允許攻擊者提供的物件遭到還原序列化;以及 d) 攻擊者從 FileStore 所使用的儲存位置知道攻擊者可控制之檔案的相關檔案路徑;則攻擊者將可使用特製的要求,透過對其控制之下的檔案還原序列化來觸發遠端程式碼執行弱點。請注意,a) 至 d) 的所有條件都必須為 true,攻擊才會成功。(CVE-2020-9484)

- CVE-2020-9484 的修正不完整。- 使用 Apache Tomcat 10.0.0-M1 至 10.0.0、9.0.0.M1 至 9.0.41 、8.5.0 至 8.5.61 或 7.0.0 至 7.0.107 (具有不太可能使用的組態邊緣案例) 時,Tomcat 執行個體仍容易受到 CVE-2020-9494 影響。請注意,先前公佈的 CVE-2020-9484 的先決條件和先前公佈的 CVE-2020-9484 的緩解措施也適用於這個問題。(CVE-2021-25329)

- 當回應新的 h2c 連線要求時,Apache Tomcat 10.0.0-M1 至 10.0.0、9.0.0.M1 至 9.0.41 以及 8.5.0 至 8.5.61 版可將要求標頭和數量有限的要求內文從一個要求復製到另一個要求,這表示使用者 A 和使用者 B 都可以看到使用者 A 要求的結果。
(CVE-2021-25122)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級版本至 Apache Tomcat 10.0.2 或更新版本。

另請參閱

http://www.nessus.org/u?6ed8976b

http://www.nessus.org/u?d7b0c6a5

http://www.nessus.org/u?b2e22528

Plugin 詳細資訊

嚴重性: High

ID: 150856

檔案名稱: tomcat_10_0_2.nasl

版本: 1.7

類型: combined

代理程式: windows, macosx, unix

系列: Web Servers

已發布: 2021/6/17

已更新: 2022/12/5

組態: 啟用徹底檢查

支持的傳感器: Nessus Agent

風險資訊

VPR

風險因素: High

分數: 8.4

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 3.9

媒介: AV:N/AC:L/Au:N/C:P/I:N/A:N

時間媒介: E:POC/RL:OF/RC:C

CVSS 評分資料來源: CVE-2021-25122

CVSS v3

風險因素: High

基本分數: 7.5

時間分數: 6.7

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

時間媒介: E:P/RL:O/RC:C

弱點資訊

CPE: cpe:/a:apache:tomcat

必要的 KB 項目: installed_sw/Apache Tomcat

可被惡意程式利用: true

可輕鬆利用: Exploits are available

弱點發布日期: 2020/5/11

參考資訊

CVE: CVE-2020-9484, CVE-2021-25122, CVE-2021-25329

IAVA: 2020-A-0225-S, 2020-A-0324, 2021-A-0114-S

CEA-ID: CEA-2021-0004