Scientific Linux 安全性更新:SL7.x i686/x86_64 上的 qt5-qtimageformats (2021:2328)

critical Nessus Plugin ID 150711

語系:

新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Scientific Linux 主機缺少一個或多個安全性更新。

描述

遠端 Scientific Linux 7 主機上安裝的多個套件受到 SLSA-2021: 2328-1 公告中提及的多個弱點影響。

-libwebp:PutLE16() 中的堆積型緩衝區溢位 (CVE-2018-25011)

-libwebp:在 ReadSymbol() 中使用未初始化的值 (CVE-2018-25014)

-libwebp:WebPDecode*Into function 中的堆積型緩衝區溢位 (CVE-2020-36328)

-libwebp:dec/io_dec.c 的 EmitFancyRGB() 中發生釋放後使用 (CVE-2020-36329)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

更新受影響的 qt5-qtimageformats、qt5-qtimageformats-debuginfo 和/或 qt5-qtimageformats-doc 套件。

另請參閱

https://www.scientificlinux.org/category/sl-errata/slsa-20212328-1

Plugin 詳細資訊

嚴重性: Critical

ID: 150711

檔案名稱: sl_20210609_qt5_qtimageformats_on_SL7_x.nasl

版本: 1.2

類型: local

代理程式: unix

已發布: 2021/6/11

已更新: 2021/6/11

相依性: ssh_get_info.nasl

風險資訊

CVSS 評分資料來源: CVE-2020-36329

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.5

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 8.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/o:fermilab:scientific_linux, p-cpe:/a:fermilab:scientific_linux:qt5-qtimageformats, p-cpe:/a:fermilab:scientific_linux:qt5-qtimageformats-debuginfo, p-cpe:/a:fermilab:scientific_linux:qt5-qtimageformats-doc

必要的 KB 項目: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2021/6/9

弱點發布日期: 2021/5/21

參考資訊

CVE: CVE-2018-25011, CVE-2018-25014, CVE-2020-36328, CVE-2020-36329