PHP 7.4.x < 7.4.18 / 8.x < 8.0.5 整數溢位

high Nessus Plugin ID 149348
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Web 伺服器上執行的 PHP 版本受到整數溢位弱點影響。

描述

遠端主機上安裝的 PHP 版本為 7.4.x 的 7.4.18 之前版本或 8.x 的 8.0.5 之前版本。因此,會受到 pnctl_exec() 中一個整數溢位問題的影響。攻擊者可惡意利用此弱點,引發拒絕服務情形或執行任意程式碼。

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本

解決方案

升級至 PHP 7.4.18、8.0.5 或更新版本。

另請參閱

https://www.php.net/ChangeLog-7.php#7.4.18

https://www.php.net/ChangeLog-8.php#8.0.5

Plugin 詳細資訊

嚴重性: High

ID: 149348

檔案名稱: php_8_0_5.nasl

版本: 1.2

類型: remote

系列: CGI abuses

已發布: 2021/5/7

已更新: 2021/6/3

相依性: php_version.nasl

風險資訊

CVSS 評分資料來源: manual

CVSS 評分論據: Score based on analysis of vendor advisory.

CVSS v2

風險因素: Medium

基本分數: 6.8

媒介: AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3

風險因素: High

基本分數: 8.3

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP, installed_sw/PHP

修補程式發佈日期: 2021/4/29

弱點發布日期: 2021/4/29

參考資訊

IAVA: 2021-A-0210-S