Oracle Business Intelligence Publisher 多個弱點 (2021 年 4 月 CPU)

critical Nessus Plugin ID 148980

Synopsis

遠端主機受到多個弱點影響。

描述

遠端主機上執行的 Oracle Business Intelligence Publisher 版本或 Oracle Analytics Server 5.5 是 11.1.1.9.210215 之前的 11.1.1.9.x 版、12.2.1.3.210405 之前的 12.2.1.3.x 版、12.2.1.4.210402 之前的 12.2.1.4.x 版或 12.2.5.5.210331 之前的 12.2.5.5.x 版 (OAS 5.5)。因此,該應用程式受到「2021 年 4 月重大修補程式更新」公告所述的下列多個弱點影響:

- 在 Oracle BI 企業版子元件 Apache Spark 中,Analytics Server 元件存在一個不明弱點。未經驗證的遠端攻擊者可透過 HTTP 惡意利用此弱點,接管 Oracle BI 企業版。(CVE-2020-9480)

- 在 Oracle BI 企業版子元件 OpenSSL 中,BI Platform Security 元件中存在一個拒絕服務弱點。未經驗證的遠端攻擊者可透過 HTTPS 惡意利用此弱點,造成產品懸置或重複當機。(CVE-2020-1971)

- 在 Oracle BI 企業版子元件 Apache Tomcat 中,BI Platform Security 元件存在一個不明弱點。未經驗證的遠端攻擊者可透過 HTTP 利用此弱點,造成未經授權即可更新、插入或刪除部分 Oracle BI 可存取資料,並且可以未經授權讀取 Oracle BI 可存取資料的子集。(CVE-2019-0221)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

按照 2021 年 4 月 Oracle 重要修補程式更新公告,套用適當的修補程式。

另請參閱

https://www.oracle.com/security-alerts/cpuapr2021.html

https://www.oracle.com/a/tech/docs/cpuapr2021cvrf.xml

Plugin 詳細資訊

嚴重性: Critical

ID: 148980

檔案名稱: oracle_bi_publisher_apr_2021_cpu.nasl

版本: 1.4

類型: local

代理程式: windows, macosx, unix

系列: Misc.

已發布: 2021/4/26

已更新: 2022/12/5

組態: 啟用徹底檢查

支持的傳感器: Nessus Agent

風險資訊

VPR

風險因素: High

分數: 7.4

CVSS v2

風險因素: High

基本分數: 9.3

時間分數: 7.3

媒介: AV:N/AC:M/Au:N/C:C/I:C/A:C

時間媒介: E:POC/RL:OF/RC:C

CVSS 評分資料來源: CVE-2020-9480

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 8.8

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:P/RL:O/RC:C

弱點資訊

CPE: cpe:/a:oracle:fusion_middleware, cpe:/a:oracle:business_intelligence_publisher

必要的 KB 項目: installed_sw/Oracle Business Intelligence Publisher

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2021/4/20

弱點發布日期: 2019/5/28

參考資訊

CVE: CVE-2019-0221, CVE-2020-1971, CVE-2020-9480, CVE-2020-11022, CVE-2021-2152, CVE-2021-2191

IAVA: 2021-A-0196

CEA-ID: CEA-2021-0004, CEA-2021-0025