WordPress 5.7 < 5.7.1 / 5.6 < 5.6.3 / 5.5 < 5.5.4 / 5.4 < 5.4.5 / 5.3 < 5.3.7 / 5.2 < 5.2.10 / 5.1 < 5.1.9 / 5.0 < 5.0.12 / 4.9 < 4.9.17 / 4.8 < 4.8.16 / 4.7 < 4.7.20

medium Nessus Plugin ID 148844
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端網頁伺服器上執行的 PHP 應用程式受到多個弱點的影響。

描述

WordPress 5.7 < 5.7.1 / 5.6 < 5.6.3 / 5.5 < 5.5.4 / 5.4 < 5.4.5 / 5.3 < 5.3.7 / 5.2 < 5.2.10 / 5.1 < 5.1.9 / 5.0 < 5.0.12 / 4.9 < 4.9.17 / 4.8 < 4.8.16 / 4.7 < 4.7.20 受到多個弱點影響:

- 能夠上傳檔案的使用者 (例如 Author) 可惡意利用媒體程式庫中的 XML 剖析問題,發動 XXE 攻擊。這需要安裝的 WordPress 使用 PHP8。若 XXE 攻擊成功,攻擊者可以存取內部檔案。(CVE-2021-29447)

- WordPress 編輯器中有一個區塊可遭惡意使用者利用,造成受密碼保護的貼文和頁面洩漏。這至少需要參與者權限。(CVE-2021-29450)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 WordPress 5.7.1、5.6.3、5.5.4、5.4.5、5.3.7、5.2.10、5.1.9、5.0.12、4.9.17、4.8.16、4.7.10 或更新版本。

另請參閱

http://www.nessus.org/u?00aa3f86

https://wordpress.org/support/wordpress-version/version-5-7-1/

https://wordpress.org/download/releases/

Plugin 詳細資訊

嚴重性: Medium

ID: 148844

檔案名稱: wordpress_5_7_1.nasl

版本: 1.8

類型: remote

系列: CGI abuses

已發布: 2021/4/20

已更新: 2021/9/16

相依性: wordpress_detect.nasl

組態: 啟用 Paranoid 模式

風險資訊

CVSS 評分資料來源: CVE-2021-29450

VPR

風險因素: Medium

分數: 6.1

CVSS v2

風險因素: Medium

基本分數: 4

時間分數: 3.1

媒介: AV:N/AC:L/Au:S/C:P/I:N/A:N

時間媒介: E:POC/RL:OF/RC:C

CVSS v3

風險因素: Medium

基本分數: 4.3

時間分數: 3.9

媒介: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

時間媒介: E:P/RL:O/RC:C

弱點資訊

CPE: cpe:/a:wordpress:wordpress

必要的 KB 項目: www/PHP, installed_sw/WordPress, Settings/ParanoidReport

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2021/4/15

弱點發布日期: 2021/4/15

參考資訊

CVE: CVE-2021-29447, CVE-2021-29450

IAVA: 2021-A-0182-S