Tenable.sc 5.16.0 / 5.17.0 OpenSSL DoS (TNS-2021-06)

medium Nessus Plugin ID 148404
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端主機上安裝的一個應用程式受到一個拒絕服務弱點影響。

描述

根據其自我報告的版本,遠端主機上安裝的 Tenable.sc 應用程式為 5.16.0 或 5.17.0 版本,受到 OpenSSL 中下列拒絕服務弱點的影響:

- 如果從用戶端傳送惡意特製的重新交涉 ClientHello 訊息,OpenSSL TLS 伺服器可能會當機。如果 TLSv1.2 重新交涉 ClientHello 省略 signature_algorithms 延伸模組 (出現在初始 ClientHello 中),但包含一個 signature_algorithms_cert 延伸模組,則會導致 NULL 指標解除參照,進而導致當機和拒絕服務攻擊。伺服器只有在已啟用 TLSv1.2 和重新交涉 (預設組態) 的情況下,才會受到影響。OpenSSL TLS 用戶端不受此問題影響。所有 OpenSSL 1.1.1 版本皆受到此問題影響。這些版本的使用者應升級至 OpenSSL 1.1.1k。OpenSSL 1.0.2 不受此問題影響。已在 OpenSSL 1.1.1k 中修復 (受影響的是 1.1.1-1.1.1j)。(CVE-2021-3449)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

安裝 Tenable.sc 修補程式 SC-202104.1或者更新至 5.18.0 版或更新版本。

另請參閱

https://www.tenable.com/security/tns-2021-06

http://www.nessus.org/u?c531f5e9

Plugin 詳細資訊

嚴重性: Medium

ID: 148404

檔案名稱: securitycenter_5_17_0_tns_2021_06.nasl

版本: 1.10

類型: local

代理程式: unix

系列: Misc.

已發布: 2021/4/9

已更新: 2021/9/23

相依性: securitycenter_installed.nbin

風險資訊

CVSS 評分資料來源: CVE-2021-3449

VPR

風險因素: Medium

分數: 6.9

CVSS v2

風險因素: Medium

基本分數: 4.3

時間分數: 3.2

媒介: AV:N/AC:M/Au:N/C:N/I:N/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: Medium

基本分數: 5.9

時間分數: 5.2

媒介: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:tenable:securitycenter

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2021/4/5

弱點發布日期: 2021/3/25

參考資訊

CVE: CVE-2021-3449

IAVA: 2021-A-0149-S