Squid 2.x < 4.14 / 5.x < 5.0.5 (SQUID-2020: 11)

high Nessus Plugin ID 148111
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Proxy 伺服器受到一個 HTTP 要求走私弱點影響

描述

根據其標題,遠端主機上執行的 Squid 版本為 4.14 之前的 2.x 版或 5.0.5 之前的 5.x 版。
因此會受到一個 HTTP 要求走私弱點影響,這是因為未正確驗證輸入所導致。組態設定中的某些 uri_whitespace 會發生此問題。這可讓受信任的用戶端執行 HTTP 要求走私,並存取 Squid 安全性控制原本禁止的服務。

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級版本至 Squid 4.14、5.05 或更新版本。

另請參閱

http://www.nessus.org/u?94d2ab4c

Plugin 詳細資訊

嚴重性: High

ID: 148111

檔案名稱: squid_5_0_5.nasl

版本: 1.5

類型: remote

系列: Firewalls

已發布: 2021/3/25

已更新: 2021/4/1

相依性: squid_version.nasl

組態: 啟用 Paranoid 模式

風險資訊

CVSS 評分資料來源: CVE-2020-25097

VPR

風險因素: Medium

分數: 4.4

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 3.7

媒介: AV:N/AC:L/Au:N/C:P/I:N/A:N

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: High

基本分數: 8.6

時間分數: 7.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:squid-cache:squid

必要的 KB 項目: installed_sw/Squid, Settings/ParanoidReport

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2021/2/8

弱點發布日期: 2020/9/3

參考資訊

CVE: CVE-2020-25097

IAVB: 2021-B-0021