pfSense 2.4.x < 2.4.5-p1 多個弱點

high Nessus Plugin ID 146206

Synopsis

遠端防火牆主機受到多個弱點影響。

描述

根據其自我報告的版本號碼,遠端 pfSense 安裝版本為 2.4.5-p1 之前的 2.4.x 版。因此,會受到子元件中的如下弱點影響:

- Unbound 1.10.1 之前版本具有網路訊息量控制不充分的弱點,即 NXNSAttack 問題。此問題由 NS 記錄中 NSDNAME 中的隨機子網域所觸發。(CVE-2020-12662)

- Unbound 1.10.1 之前版本會透過從上游伺服器接收的格式錯誤的 DNS 回應造成無限迴圈。
(CVE-2020-12663)

- json-c 0.14 及之前所有版本存在透過大型 JSON 檔案造成的整數溢位和超出邊界寫入問題,printbuf_memappend 即為一例。(CVE-2020-12762)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級版本至 pfSense 2.4.5-p1 或更新版本,或套用廠商公告中所述的修補程式。

另請參閱

https://docs.netgate.com/pfsense/en/latest/releases/2-4-5-p1.html

Plugin 詳細資訊

嚴重性: High

ID: 146206

檔案名稱: pfsense_2_4_5_p1.nasl

版本: 1.2

類型: remote

系列: Firewalls

已發布: 2021/2/4

已更新: 2021/2/5

風險資訊

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: Medium

基本分數: 6.8

時間分數: 5

媒介: AV:N/AC:M/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2020-12762

CVSS v3

風險因素: High

基本分數: 7.8

時間分數: 6.8

媒介: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:pfsense:pfsense, cpe:/a:bsdperimeter:pfsense, cpe:/a:netgate:pfsense

必要的 KB 項目: Host/pfSense

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2020/6/9

弱點發布日期: 2020/5/9

參考資訊

CVE: CVE-2020-12662, CVE-2020-12663, CVE-2020-12762