pfSense 2.4.x < 2.4.4-p1 多個弱點 (SA-18_09)

high Nessus Plugin ID 146059

Synopsis

遠端防火牆主機受到多個弱點影響。

描述

根據其自我報告的版本號碼,遠端 pfSense 安裝版本為 2.4.4-p1 之前的 2.4.x 版。因此會受到包括以下在內的多個弱點影響:

- Netgate pfSense CE 2.4.4-RELEASE 處理特定 POST 要求的參數時,其處理方式中存在一個可遭惡意利用的命令插入弱點。遠端攻擊者可利用此問題,在系統中執行任意命令。攻擊者需要能夠傳送經驗證的 POST 要求至管理 Web 介面。在「powerd_normal_mode」參數中可能會發生命令插入。(CVE-2018-4019)

- Netgate pfSense CE 2.4.4-RELEASE 處理特定 POST 要求的參數時,其處理方式中存在一個可遭惡意利用的命令插入弱點。遠端攻擊者可利用此問題,在系統中執行任意命令。攻擊者需要能夠傳送經驗證的 POST 要求至管理 Web 介面。在「powerd_ac_mode」POST 參數中可能會發生命令插入。(CVE-2018-4020)

- Netgate pfSense CE 2.4.4-RELEASE 處理特定 POST 要求的參數時,其處理方式中存在一個可遭惡意利用的命令插入弱點。遠端攻擊者可利用此問題,在系統中執行任意命令。攻擊者需要能夠傳送經驗證的 POST 要求至管理 Web 介面。在「powerd_battery_mode」POST 參數中可能會發生命令插入。(CVE-2018-4021)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級版本至 pfSense 2.4.4-p1 或更新版本,或套用廠商公告中所述的修補程式。

另請參閱

http://www.nessus.org/u?a654a213

https://docs.netgate.com/pfsense/en/latest/releases/2-4-4-p1.html

Plugin 詳細資訊

嚴重性: High

ID: 146059

檔案名稱: pfsense_2_4_4_p1.nasl

版本: 1.2

類型: remote

系列: Firewalls

已發布: 2021/2/2

已更新: 2021/2/3

風險資訊

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: Medium

基本分數: 6.5

時間分數: 4.8

媒介: AV:N/AC:L/Au:S/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2018-4019

CVSS v3

風險因素: High

基本分數: 7.2

時間分數: 6.3

媒介: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:pfsense:pfsense, cpe:/a:bsdperimeter:pfsense, cpe:/a:netgate:pfsense

必要的 KB 項目: Host/pfSense

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2018/11/15

弱點發布日期: 2018/9/28

參考資訊

CVE: CVE-2018-4019, CVE-2018-4020, CVE-2018-4021, CVE-2018-6925, CVE-2018-17154, CVE-2018-17155