PHP 7.3.x < 7.3.26 / 7.4.x < 7.4.14 / 8.x < 8.0.1 輸入驗證錯誤

medium Nessus Plugin ID 144947
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Web 伺服器上執行的 PHP 版本受到輸入驗證錯誤影響

描述

遠端主機上安裝的 PHP 版本為 7.3.26 之前的 7.3.x 版、7.4.14 之前的 7.4.x 版或 8.0.1 之前的 8.x 版。
因此會受到輸入驗證錯誤影響,這是個別修正版本的變更記錄所指明的 URL 驗證不足所致。未經驗證的遠端攻擊者可利用此錯誤,透過納入「@」字元繞過 URL 篩選。

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本

解決方案

升級至 PHP 7.3.26 版、7.4.14 版、8.0.1 版或更新版本。

另請參閱

https://www.php.net/ChangeLog-7.php#7.3.26

https://www.php.net/ChangeLog-7.php#7.4.14

https://www.php.net/ChangeLog-8.php#8.0.1

Plugin 詳細資訊

嚴重性: Medium

ID: 144947

檔案名稱: php_8_0_1.nasl

版本: 1.5

類型: remote

系列: CGI abuses

已發布: 2021/1/14

已更新: 2021/2/25

相依性: php_version.nasl

風險資訊

CVSS 評分資料來源: CVE-2020-7071

VPR

風險因素: Low

分數: 2.2

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 3.7

媒介: AV:N/AC:L/Au:N/C:N/I:P/A:N

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: Medium

基本分數: 5.3

時間分數: 4.6

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP, installed_sw/PHP

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2021/1/7

弱點發布日期: 2021/1/7

參考資訊

CVE: CVE-2020-7071

IAVA: 2021-A-0009-S