IBM HTTP Server 7.0.0.0 <= 7.0.0.43 / 8.0.0.0 <= 8.0.0.14 / 8.5.0.0 < 8.5.5.14 / 9.0.0.0 < 9.0.0.8 多個弱點 (569295)

high Nessus Plugin ID 144780
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Web 伺服器受到多個弱點影響。

描述

遠端主機上執行的 IBM HTTP Server 版本受到與 Apache HTTP Server 有關的多個弱點影響,具體如下:

- 特別建構的要求可能損毀 Apache HTTP Server 2.4.30 之前的版本,這是在讀取 HTTP 標頭達到大小限制後造成超出邊界存取所致。此弱點被視為在非偵錯模式 (記錄和建置層級) 下非常難以觸發 (如果並非不可能),因此針對一般伺服器使用,會被分類為低風險。(CVE-2018-1301)

- 在 Apache httpd 2.0.23 至 2.0.65、2.2.0 至 2.2.34 和 2.4.0 至 2.4.29 中,如果使用 AuthLDAPCharsetConfig 設定,mod_authnz_ldap 會在驗證使用者的憑證時,使用 Accept-Language 標頭值查閱正確的字元集編碼。如果字元集轉換表中沒有標頭值,則會使用後援機制將其截斷成兩個字元的值,以允許快速重試 (例如,「en-US」被截斷成「en」)。少於兩個字元的標頭值會強制將一個 NUL 位元組超出邊界寫入不屬於該字串的記憶體位置。在最糟的情況 (不太可能) 下,處理程序損毀會被用作拒絕服務攻擊。在比較可能的情況下,此記憶體已保留供日後使用,因此該問題不會造成任何影響。(CVE-2017-15710)

- 在 Apache httpd 2.4.0 至 2.4.29 中,<FilesMatch> 內指定的運算式可以將「$」與惡意檔案名稱中的新行字元比對,而不是只比對檔案名稱的結尾。在外部封鎖部分檔案上傳的環境中,此問題可能會遭到惡意利用,但只能透過比對檔案名稱的結尾部分來利用。(CVE-2017-15715)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 IBM HTTP Server 8.5.5.14、9.0.0.8 或更新版本。或者,升級版本至過渡期修正所需的最低 Fix Pack 等級,然後套用過渡期修正 PI95670。

另請參閱

https://www.ibm.com/support/pages/node/569295

Plugin 詳細資訊

嚴重性: High

ID: 144780

檔案名稱: ibm_http_server_569295.nasl

版本: 1.3

類型: local

代理程式: unix

系列: Web Servers

已發布: 2021/1/6

已更新: 2021/1/25

相依性: ibm_http_server_nix_installed.nbin

風險資訊

CVSS 評分資料來源: CVE-2017-15715

VPR

風險因素: High

分數: 7.4

CVSS v2

風險因素: Medium

基本分數: 6.8

時間分數: 5

媒介: AV:N/AC:M/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: High

基本分數: 8.1

時間分數: 7.1

媒介: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:ibm:http_server

必要的 KB 項目: installed_sw/IBM HTTP Server (IHS)

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2020/4/11

弱點發布日期: 2020/3/26

參考資訊

CVE: CVE-2017-15710, CVE-2017-15715, CVE-2018-1301

BID: 103512, 103515, 103525