phpMyAdmin 4.9.0 < 4.9.5 / 5.0.0 < 5.0.2 多個弱點 (PMASA-2020-2、PMASA-2020-3、PMASA-2020-4)

high Nessus Plugin ID 144646
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Web 伺服器主控一個受多個弱點影響的 PHP 應用程式。

描述

根據其自我報告的版本,遠端 Web 伺服器上主控的 phpMyAdmin 應用程式為 4.9.5 之前的 4.9.x 版、5.0.2 之前的 5.0.x 版。因此,會受到多個弱點影響。

- 在 phpMyAdmin 4.9.5 之前的 4.x 版和 5.0.2之前的 5.x版中,當前使用者名稱 (libraries/classes/Server/Privileges.php and libraries/classes/UserPassword.php 中) 的擷取中發現 SQL 插入弱點。如果惡意使用者具有伺服器存取權,則可建立建構的使用者名稱,然後誘騙受害者使用該使用者帳戶執行特定動作 (例如編輯其權限)。(CVE-2020-10804)

- 在 phpMyAdmin 4.9.5 之前的 4.x 版和 5.0.2 之前的 5.x 版中發現 SQL 插入弱點,其中針對 libraries/classes/Controllers/Table/TableSearchController.php 中的搜尋動作產生特定查詢時,某些參數未正確逸出。攻擊者可產生建構的資料庫或表格名稱。如果使用者嘗試對惡意資料庫或表格執行特定搜尋作業,就可觸發此攻擊。(CVE-2020-10802)

- 在 phpMyAdmin 4.9.5 之前的 4.x 版和 5.0.2 之前的 5.x 版中發現 SQL 弱點,攻擊者可利用此弱點,透過擷取和顯示結果 (tbl_get_field.php and libraries/classes/Display/Results.php 中),使用惡意程式碼觸發 XSS 攻擊。攻擊者必須能夠將建構的資料插入特定資料庫表格,這些資料可在擷取 (例如透過「瀏覽」索引標籤) 時,觸發 XSS 攻擊。(CVE-2020-10803)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 phpMyAdmin 4.9.5 / 5.0.2 或更新版本。

另請參閱

https://www.phpmyadmin.net/security/PMASA-2020-2/

https://www.phpmyadmin.net/security/PMASA-2020-3/

https://www.phpmyadmin.net/security/PMASA-2020-4/

Plugin 詳細資訊

嚴重性: High

ID: 144646

檔案名稱: phpmyadmin_pmasa_5_0_2.nasl

版本: 1.3

類型: remote

系列: CGI abuses

已發布: 2020/12/30

已更新: 2021/1/4

相依性: phpMyAdmin_detect.nasl

組態: 啟用 Paranoid 模式

風險資訊

CVSS 評分資料來源: CVE-2020-10802

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: Medium

基本分數: 6

時間分數: 4.4

媒介: AV:N/AC:M/Au:S/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: High

基本分數: 8

時間分數: 7

媒介: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:phpmyadmin:phpmyadmin

必要的 KB 項目: www/PHP, installed_sw/phpMyAdmin, Settings/ParanoidReport

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2020/3/21

弱點發布日期: 2020/3/20

參考資訊

CVE: CVE-2020-10802, CVE-2020-10803, CVE-2020-10804

CWE: 661