AIX 7.1 TL 5:perl (IJ26985)

high Nessus Plugin ID 144314

Synopsis

遠端 AIX 主機缺少安全性修補程式。

描述

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-10543 https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-10543 32 位元平台上的 Perl 5.30.3 之前版本允許發生堆積型緩衝區溢位,這是因為巢狀規則運算式數量詞存在整數溢位問題所導致。Perl 5.30.3 之前版本存在整數溢位問題,這與程式錯誤處理「PL_regkind [OP(n)] == NOTHING」情況有關。特別建構的規則運算式由於可能插入指令,因此可導致位元組程式碼格式錯誤。在 Perl 5.30.3 之前版本中,regcomp.c 允許透過特別建構的規則運算式造成緩衝區溢位,這是因為遞回 S_study_chunk 呼叫所導致。

解決方案

安裝適當的過渡期修正。

另請參閱

http://aix.software.ibm.com/aix/efixes/security/perl_advisory5.asc

Plugin 詳細資訊

嚴重性: High

ID: 144314

檔案名稱: aix_IJ26985.nasl

版本: 1.4

類型: local

已發布: 2020/12/16

已更新: 2021/3/5

風險資訊

VPR

風險因素: Medium

分數: 5.5

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.5

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: High

基本分數: 8.6

時間分數: 7.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/o:ibm:aix:7.1

必要的 KB 項目: Host/AIX/lslpp, Host/local_checks_enabled, Host/AIX/version

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2020/12/9

弱點發布日期: 2020/12/9

參考資訊

CVE: CVE-2020-10543, CVE-2020-10878, CVE-2020-12723