phpMyAdmin 4.0.x < 4.0.10.18 / 4.4.x < 4.4.15.9 / 4.6.x < 4.6.5 多個弱點

critical Nessus Plugin ID 143532

Synopsis

遠端 Web 伺服器主控一個受多個弱點影響的 PHP 應用程式。

描述

根據其自我報告的版本,遠端 Web 伺服器上主控的 phpMyAdmin 應用程式為 4.0.10.18 之前的 4.0.x 版、4.4.15.9 之前的 4.4.x 版或 4.6.5 之前的 4.6.x 版。因此,會受到多個弱點影響。

- 在 phpMyAdmin 版本中發現一個問題。當使用者未指定用來加密 Cookie 的 blowfish_secret 金鑰時,phpMyAdmin 會在執行階段產生一個金鑰。據報告,若使用弱式演算法建立此值,會存在一個弱點。攻擊者可利用此弱點判斷使用者的 blowfish_secret,並可能解密其 Cookie。所有 4.6.x 版本 (4.6.5 之前版本)、4.4.x 版本 (4.4.15.9 之前版本) 以及 4.0.x 版本 (4.0.10.18 之前版本) 均會受到影響。(CVE-2016-9847)

- 在 phpMyAdmin 中發現一個問題。phpinfo (phpinfo.php) 會顯示 PHP 資訊,包括 HttpOnly Cookie 的值。所有 4.6.x 版本 (4.6.5 之前版本)、4.4.x 版本 (4.4.15.9 之前版本) 以及 4.0.x 版本 (4.0.10.18 之前版本) 均會受到影響。(CVE-2016-9848)

- 在 phpMyAdmin 版本中發現一個問題。攻擊者可以在使用者名稱中使用 Null 位元組,藉此繞過 AllowRoot 限制 ($cfg ['Servers'] [$i] ['AllowRoot'])並拒絕使用者名稱規則。所有 4.6.x 版本 (4.6.5 之前版本)、4.4.x 版本 (4.4.15.9 之前版本) 以及 4.0.x 版本 (4.0.10.18 之前版本) 均會受到影響。(CVE-2016-9849)

- 在 phpMyAdmin 版本中發現一個問題。允許/拒絕規則的使用者名稱比對可能會因為非常數執行時間,導致發生比對錯誤或偵測到規則內的使用者名稱。所有 4.6.x 版本 (4.6.5 之前版本)、4.4.x 版本 (4.4.15.9 之前版本) 以及 4.0.x 版本 (4.0.10.18 之前版本) 均會受到影響。(CVE-2016-9850)

- 在 phpMyAdmin 版本中發現一個問題。透過特製的要求參數值,可以繞過登出逾時。所有 4.6.x 版本 (4.6.5 之前版本) 和 4.4.x 版本 (4.4.15.9 之前版本) 均會受到影響。
(CVE-2016-9851)

- 在 phpMyAdmin 版本中發現一個問題。如果以未預期的方式,呼叫屬於 phpMyAdmin 的指令碼,則可能會觸發 phpMyAdmin 來顯示 PHP 錯誤訊息,其中提供 phpMyAdmin 安裝目錄的完整路徑。在匯出功能的執行逾時期間,包含 phpMyAdmin 目錄完整路徑的錯誤會寫入匯出檔案。所有 4.6.x 版本 (4.6.5 之前版本) 和 4.4.x 版本 (4.4.15.9 之前版本) 均會受到影響。
此 CVE 適用於 curl 包裝函式問題。(CVE-2016-9852)

- 在 phpMyAdmin 版本中發現一個問題。如果以未預期的方式,呼叫屬於 phpMyAdmin 的指令碼,則可能會觸發 phpMyAdmin 來顯示 PHP 錯誤訊息,其中提供 phpMyAdmin 安裝目錄的完整路徑。在匯出功能的執行逾時期間,包含 phpMyAdmin 目錄完整路徑的錯誤會寫入匯出檔案。所有 4.6.x 版本 (4.6.5 之前版本) 和 4.4.x 版本 (4.4.15.9 之前版本) 均會受到影響。
此 CVE 適用於 fopen 包裝函式問題。(CVE-2016-9853)

- 在 phpMyAdmin 版本中發現一個問題。如果以未預期的方式,呼叫屬於 phpMyAdmin 的指令碼,則可能會觸發 phpMyAdmin 來顯示 PHP 錯誤訊息,其中提供 phpMyAdmin 安裝目錄的完整路徑。在匯出功能的執行逾時期間,包含 phpMyAdmin 目錄完整路徑的錯誤會寫入匯出檔案。所有 4.6.x 版本 (4.6.5 之前版本) 和 4.4.x 版本 (4.4.15.9 之前版本) 均會受到影響。
此 CVE 適用於 json_decode 問題。(CVE-2016-9854)

- 在 phpMyAdmin 版本中發現一個問題。如果以未預期的方式,呼叫屬於 phpMyAdmin 的指令碼,則可能會觸發 phpMyAdmin 來顯示 PHP 錯誤訊息,其中提供 phpMyAdmin 安裝目錄的完整路徑。在匯出功能的執行逾時期間,包含 phpMyAdmin 目錄完整路徑的錯誤會寫入匯出檔案。所有 4.6.x 版本 (4.6.5 之前版本) 和 4.4.x 版本 (4.4.15.9 之前版本) 均會受到影響。
此 CVE 適用於 PMA_shutdownDuringExport 問題。(CVE-2016-9855)

- 在 phpMyAdmin 中發現一個 XSS 問題,這是因為 PMASA-2016-10 中針對 CVE-2016-2559 的修正不當所致。
已透過使用雜湊複本來避免爭用情形而解決此問題。所有 4.6.x 版本 (4.6.5 之前版本)、4.4.x 版本 (4.4.15.9 之前版本) 以及 4.0.x 版本 (4.0.10.18 之前版本) 均會受到影響。
(CVE-2016-9856)

- 在 phpMyAdmin 版本中發現一個問題。因為在某些 JavaScript 處理中使用的規則運算式中存在弱點,所以可能發生 XSS。所有 4.6.x 版本 (4.6.5 之前版本)、4.4.x 版本 (4.4.15.9 之前版本) 以及 4.0.x 版本 (4.0.10.18 之前版本) 均會受到影響。(CVE-2016-9857)

- 在 phpMyAdmin 版本中發現一個問題。透過特製的要求參數值,可以在已儲存的搜尋功能中發動拒絕服務攻擊。所有 4.6.x 版本 (4.6.5 之前版本)、4.4.x 版本 (4.4.15.9 之前版本) 以及 4.0.x 版本 (4.0.10.18 之前版本) 均會受到影響。(CVE-2016-9858)

- 在 phpMyAdmin 版本中發現一個問題。透過特製的要求參數值,可以在匯入功能中發動拒絕服務攻擊。所有 4.6.x 版本 (4.6.5 之前版本)、4.4.x 版本 (4.4.15.9 之前版本) 以及 4.0.x 版本 (4.0.10.18 之前版本) 均會受到影響。(CVE-2016-9859)

- 在 phpMyAdmin 版本中發現一個問題。在 $cfg['AllowArbitraryServer']=true 情況下執行 phpMyAdmin 時,未經驗證的使用者可發動拒絕服務攻擊。所有 4.6.x 版本 (4.6.5 之前版本)、4.4.x 版本 (4.4.15.9 之前版本) 以及 4.0.x 版本 (4.0.10.18 之前版本) 均會受到影響。(CVE-2016-9860)

- 在 phpMyAdmin 版本中發現一個問題。由於 URL 比對中的限制,可能會繞過 URL 白名單保護。所有 4.6.x 版本 (4.6.5 之前版本)、4.4.x 版本 (4.4.15.9 之前版本) 以及 4.0.x 版本 (4.0.10.18 之前版本) 均會受到影響。(CVE-2016-9861)

- 在 phpMyAdmin 版本中發現一個問題。透過特別建構的登入要求,可以在登入頁面中插入 BBCode。所有 4.6.x 版本 (早於 4.6.5) 會受到影響。(CVE-2016-9862)

- 在 phpMyAdmin 版本中發現一個問題。透過非常大型的表格分割函式要求,可以發起拒絕服務 (DoS)攻擊。所有 4.6.x 版本 (4.6.5 之前版本) 均受到影響。
(CVE-2016-9863)

- 在 phpMyAdmin 版本中發現一個問題。透過特製的使用者名稱或表格名稱,可以在以控制使用者權限執行的追踪功能中插入 SQL 陳述式。這可提供對組態儲存資料庫表格的讀取和寫入存取權,如果控制使用者具備所需的權限,也會提供對 MySQL 資料庫部分表格的讀取存取權。所有 4.6.x 版本 (4.6.5 之前版本)、4.4.x 版本 (4.4.15.9 之前版本) 以及 4.0.x 版本 (4.0.10.18 之前版本) 均會受到影響。
(CVE-2016-9864)

- 在 phpMyAdmin 版本中發現一個問題。因為序列化字串剖析中存在錯誤,造成可能會繞過 PMA_safeUnserialize() 函式提供的保護。所有 4.6.x 版本 (4.6.5 之前版本)、4.4.x 版本 (4.4.15.9 之前版本) 以及 4.0.x 版本 (4.0.10.18 之前版本) 均會受到影響。(CVE-2016-9865)

- 在 phpMyAdmin 版本中發現一個問題。當 arg_separator 與其預設值 & 不同時,未從偏好設定匯入動作的傳回 URL 正確去除 CSRF token。所有 4.6.x 版本 (4.6.5 之前版本)、4.4.x 版本 (4.4.15.9 之前版本) 以及 4.0.x 版本 (4.0.10.18 之前版本) 均會受到影響。(CVE-2016-9866)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 phpMyAdmin 4.0.10.18 / 4.4.15.9 / 4.6.5 或更新版本。

另請參閱

https://www.phpmyadmin.net/security/PMASA-2016-58/

https://www.phpmyadmin.net/security/PMASA-2016-59/

https://www.phpmyadmin.net/security/PMASA-2016-60/

https://www.phpmyadmin.net/security/PMASA-2016-61/

https://www.phpmyadmin.net/security/PMASA-2016-62/

https://www.phpmyadmin.net/security/PMASA-2016-63/

https://www.phpmyadmin.net/security/PMASA-2016-64/

https://www.phpmyadmin.net/security/PMASA-2016-65/

https://www.phpmyadmin.net/security/PMASA-2016-66/

https://www.phpmyadmin.net/security/PMASA-2016-67/

https://www.phpmyadmin.net/security/PMASA-2016-68/

https://www.phpmyadmin.net/security/PMASA-2016-69/

https://www.phpmyadmin.net/security/PMASA-2016-70/

https://www.phpmyadmin.net/security/PMASA-2016-71/

Plugin 詳細資訊

嚴重性: Critical

ID: 143532

檔案名稱: phpmyadmin_pmasa_4_6_5.nasl

版本: 1.5

類型: remote

系列: CGI abuses

已發布: 2020/12/7

已更新: 2022/4/11

組態: 啟用 Paranoid 模式, 啟用徹底檢查

風險資訊

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.5

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2016-9865

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 8.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:phpmyadmin:phpmyadmin

必要的 KB 項目: www/PHP, installed_sw/phpMyAdmin, Settings/ParanoidReport

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2016/11/25

弱點發布日期: 2016/11/25

參考資訊

CVE: CVE-2016-9847, CVE-2016-9848, CVE-2016-9849, CVE-2016-9850, CVE-2016-9851, CVE-2016-9852, CVE-2016-9853, CVE-2016-9854, CVE-2016-9855, CVE-2016-9856, CVE-2016-9857, CVE-2016-9858, CVE-2016-9859, CVE-2016-9860, CVE-2016-9861, CVE-2016-9862, CVE-2016-9863, CVE-2016-9864, CVE-2016-9865, CVE-2016-9866

BID: 94521, 94523, 94524, 94525, 94526, 94527, 94528, 94529, 94530, 94531, 94533, 94534, 94535, 94536

CWE: 20, 89, 352, 400, 601, 661