phpMyAdmin 4.0.0 < 4.0.10.17 / 4.4.0 < 4.4.15.8 / 4.6.0 < 4.6.4 多個弱點

critical Nessus Plugin ID 143282
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Web 伺服器主控一個受多個弱點影響的 PHP 應用程式。

描述

根據其自我報告的版本,遠端 Web 伺服器上主控的 phpMyAdmin 應用程式為 4.0.10.17 之前的 4.0.x 版、4.4.15.8 之前的 4.4.x 版或 4.6.4 之前的 4.6.x 版。因此,會受到多個弱點影響。

- 在 phpMyAdmin 的 Cookie 加密中發現一個問題。使用者名稱/密碼解密容易受到 padding oracle 攻擊。這可允許能夠存取使用者瀏覽器 Cookie 檔案的攻擊者解密使用者名稱與密碼。此外,還使用了相同的初始化向量 (IV) 來雜湊儲存在 phpMyAdmin cookie 中的使用者名稱和密碼。如果使用者所用的密碼與使用者名稱相同,則檢查瀏覽器 Cookie 的攻擊者即可看到其為相同,但由於 Cookie 仍受雜湊處理,所以攻擊者無法直接從 Cookie 解密這些值。所有 4.6.x 版本 (早於 4.6.4)、4.4.x 版本 (早於 4.4.15.8),以及 4.0.x 版本 (早於 4.0.10.17) 會受到影響。(CVE-2016-6606)

- 在 phpMyAdmin 中發現 XSS 問題。這會影響縮放搜尋 (可利用特別建構的欄內容觸發 XSS 攻擊);GIS 編輯器 (圖形 GIS 編輯器中的特定欄位並未正確逸出,可用於觸發 XSS 攻擊);關聯檢視;下列轉換:
Formatted、Imagelink、JPEG:Upload、RegexValidation、JPEG 內嵌、PNG 內嵌,以及轉換包裝函式;
XML 匯出;MediaWiki 匯出;Designer;當 MySQL 伺服器以特別建構的 log_bin 指示詞執行時;資料庫索引標籤;複寫功能;資料庫搜尋。所有 4.6.x 版本 (早於 4.6.4)、4.4.x 版本 (早於 4.4.15.8),以及 4.0.x 版本 (早於 4.0.10.17) 會受到影響。(CVE-2016-6607)

- 在 phpMyAdmin 中發現 XSS 問題。這會影響資料庫權限檢查和移除磁碟分割功能。特製的資料庫名稱可觸發 XSS 攻擊。所有 4.6.x 版本 (早於 4.6.4) 會受到影響。(CVE-2016-6608)

- 在 phpMyAdmin 版本中發現一個問題。特製的資料庫名稱可用來透過陣列匯出功能執行任意 PHP 命令。所有 4.6.x 版本 (早於 4.6.4)、4.4.x 版本 (早於 4.4.15.8),以及 4.0.x 版本 (早於 4.0.10.17) 會受到影響。(CVE-2016-6609)

- 在 phpMyAdmin 中發現一個完整路徑洩漏弱點,允許使用者在匯出機制中觸發特定錯誤,進而探索磁碟中 phpMyAdmin 的完整路徑。所有 4.6.x 版本 (早於 4.6.4)、4.4.x 版本 (早於 4.4.15.8),以及 4.0.x 版本 (早於 4.0.10.17) 會受到影響。(CVE-2016-6610)

- 在 phpMyAdmin 版本中發現一個問題。特別建構的資料庫和/或表格名稱可用來透過匯出功能觸發 SQL 插入攻擊。所有 4.6.x 版本 (早於 4.6.4)、4.4.x 版本 (早於 4.4.15.8),以及 4.0.x 版本 (早於 4.0.10.17) 會受到影響。(CVE-2016-6611)

- 在 phpMyAdmin 版本中發現一個問題。使用者可惡意利用 LOAD LOCAL INFILE 功能來將伺服器上的檔案洩漏給資料庫系統。所有 4.6.x 版本 (早於 4.6.4)、4.4.x 版本 (早於 4.4.15.8),以及 4.0.x 版本 (早於 4.0.10.17) 會受到影響。(CVE-2016-6612)

- 在 phpMyAdmin 版本中發現一個問題。使用者可在磁碟上特製允許 phpMyAdmin 讀取但不允許使用者讀取之檔案的符號連結,phpMyAdmin 之後會將其洩漏給使用者。所有 4.6.x 版本 (早於 4.6.4)、4.4.x 版本 (早於 4.4.15.8),以及 4.0.x 版本 (早於 4.0.10.17) 會受到影響。(CVE-2016-6613)

- 在 phpMyAdmin 中發現一個問題,該問題與 SaveDir 及 UploadDir 功能的 %u 使用者名稱取代功能有關。設定使用者名稱替代時,可使用特別建構的使用者名稱來規避遊走檔案系統的限制。所有 4.6.x 版本 (早於 4.6.4)、4.4.x 版本 (早於 4.4.15.8),以及 4.0.x 版本 (早於 4.0.10.17) 會受到影響。(CVE-2016-6614)

- 在 phpMyAdmin 中發現 XSS 問題。這會影響導覽窗格和資料庫/表格隱藏功能 (可利用特別建構的資料庫名稱觸發 XSS 攻擊);追蹤功能 (可利用特別建構的查詢觸發 XSS 攻擊);以及 GIS 視覺化功能。所有 4.6.x 版本 (早於 4.6.4) 和 4.4.x 版本 (早於 4.4.15.8) 會受到影響。(CVE-2016-6615)

- 在 phpMyAdmin 版本中發現一個問題。在使用者群組和 Designer 功能中,使用者可對控制使用者的帳戶發動 SQL 插入攻擊。所有 4.6.x 版本 (早於 4.6.4) 和 4.4.x 版本 (早於 4.4.15.8) 會受到影響。(CVE-2016-6616)

- 在 phpMyAdmin 版本中發現一個問題。特別建構的資料庫和/或表格名稱可用來透過匯出功能觸發 SQL 插入攻擊。所有 4.6.x 版本 (早於 4.6.4) 會受到影響。(CVE-2016-6617)

- 在 phpMyAdmin 版本中發現一個問題。轉換功能可允許使用者針對伺服器觸發拒絕服務 (DoS) 攻擊。所有 4.6.x 版本 (早於 4.6.4)、4.4.x 版本 (早於 4.4.15.8),以及 4.0.x 版本 (早於 4.0.10.17) 會受到影響。(CVE-2016-6618)

- 在 phpMyAdmin 版本中發現一個問題。在使用者介面偏好設定功能中,使用者可對控制使用者的帳戶發動 SQL 插入攻擊。所有 4.6.x 版本 (早於 4.6.4)、4.4.x 版本 (早於 4.4.15.8),以及 4.0.x 版本 (早於 4.0.10.17) 會受到影響。(CVE-2016-6619)

- 在 phpMyAdmin 版本中發現一個問題。部分資料未先經驗證為有效的序列化資料,即傳送至 PHP unserialize() 函式。未序列化可導致程式碼執行,這是其與物件具現化和自動載入的互動所致。所有 4.6.x 版本 (早於 4.6.4)、4.4.x 版本 (早於 4.4.15.8),以及 4.0.x 版本 (早於 4.0.10.17) 會受到影響。(CVE-2016-6620)

- 在 phpMyAdmin 版本中發現一個問題。未經驗證的使用者可在 phpMyAdmin 以 $cfg['AllowArbitraryServer']=true 執行時強制持續連線,進而發動拒絕服務 (DoS) 攻擊。所有 4.6.x 版本 (早於 4.6.4)、4.4.x 版本 (早於 4.4.15.8),以及 4.0.x 版本 (早於 4.0.10.17) 會受到影響。(CVE-2016-6622)

- 在 phpMyAdmin 版本中發現一個問題。經授權的使用者可透過傳送大值給迴圈來對伺服器造成拒絕服務 (DoS) 攻擊。所有 4.6.x 版本 (早於 4.6.4)、4.4.x 版本 (早於 4.4.15.8),以及 4.0.x 版本 (早於 4.0.10.17) 會受到影響。(CVE-2016-6623)

- 在 phpMyAdmin 中發現一個問題,該問題與不當強制執行 IP 型驗證規則有關。
當 phpMyAdmin 在代理伺服器環境中與 IPv6 搭配使用,且代理伺服器處於允許的範圍內,但不允許存在攻擊電腦時,此弱點可允許攻擊電腦忽略 IP 規則來連線。所有 4.6.x 版本 (早於 4.6.4)、4.4.x 版本 (早於 4.4.15.8),以及 4.0.x 版本 (早於 4.0.10.17) 會受到影響。(CVE-2016-6624)

- 在 phpMyAdmin 版本中發現一個問題。攻擊者可判斷使用者是否已登入 phpMyAdmin。使用者的工作階段、使用者名稱和密碼都不會因此弱點而遭到入侵。所有 4.6.x 版本 (早於 4.6.4)、4.4.x 版本 (早於 4.4.15.8),以及 4.0.x 版本 (早於 4.0.10.17) 會受到影響。(CVE-2016-6625)

- 在 phpMyAdmin 版本中發現一個問題。攻擊者可將使用者重新導向至惡意網頁。所有 4.6.x 版本 (早於 4.6.4)、4.4.x 版本 (早於 4.4.15.8),以及 4.0.x 版本 (早於 4.0.10.17) 會受到影響。(CVE-2016-6626)

- 在 phpMyAdmin 版本中發現一個問題。攻擊者可透過檔案 url.php 來判斷 phpMyAdmin 主機位置。所有 4.6.x 版本 (早於 4.6.4)、4.4.x 版本 (早於 4.4.15.8),以及 4.0.x 版本 (早於 4.0.10.17) 會受到影響。(CVE-2016-6627)

- 在 phpMyAdmin 版本中發現一個問題。攻擊者或可觸發使用者下載特別建構的惡意 SVG 檔案。所有 4.6.x 版本 (早於 4.6.4)、4.4.x 版本 (早於 4.4.15.8),以及 4.0.x 版本 (早於 4.0.10.17) 會受到影響。(CVE-2016-6628)

- 在 phpMyAdmin 中發現一個問題,該問題與 $cfg['ArbitraryServerRegexp'] 組態指示詞有關。
攻擊者可繞過 ArbitraryServerRegexp 定義的伺服器,藉此重新使用特定 cookie 值。所有 4.6.x 版本 (早於 4.6.4)、4.4.x 版本 (早於 4.4.15.8),以及 4.0.x 版本 (早於 4.0.10.17) 會受到影響。(CVE-2016-6629)

- 在 phpMyAdmin 版本中發現一個問題。經驗證的使用者可在變更密碼對話方塊中輸入極長的密碼,進而觸發拒絕服務 (DoS) 攻擊。所有 4.6.x 版本 (早於 4.6.4)、4.4.x 版本 (早於 4.4.15.8),以及 4.0.x 版本 (早於 4.0.10.17) 會受到影響。(CVE-2016-6630)

- 在 phpMyAdmin 版本中發現一個問題。在 phpMyAdmin 做為 CGI 應用程式執行時,使用者可對伺服器發動遠端程式碼執行攻擊。在特定伺服器組態下,使用者可傳送由 generator_plugin.sh 檔案以命令行引數執行的查詢字串。所有 4.6.x 版本 (早於 4.6.4)、4.4.x 版本 (早於 4.4.15.8),以及 4.0.x 版本 (早於 4.0.10.17) 會受到影響。(CVE-2016-6631)

- 在 phpMyAdmin 中發現一個問題,在某些情況下,phpMyAdmin 在匯入 ESRI 檔案時可能不會刪除暫存檔。所有 4.6.x 版本 (早於 4.6.4)、4.4.x 版本 (早於 4.4.15.8),以及 4.0.x 版本 (早於 4.0.10.17) 會受到影響。(CVE-2016-6632)

- 在 phpMyAdmin 中發現一個問題。 phpMyAdmin 可用來針對某些以 dbase 延伸模組執行的 PHP 安裝觸發遠端程式碼執行弱點。所有 4.6.x 版本 (早於 4.6.4)、4.4.x 版本 (早於 4.4.15.8),以及 4.0.x 版本 (早於 4.0.10.17) 會受到影響。
(CVE-2016-6633)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 phpMyAdmin 4.0.10.17 / 4.4.15.8 / 4.6.4 或更新版本。

另請參閱

https://www.phpmyadmin.net/security/PMASA-2016-29/

https://www.phpmyadmin.net/security/PMASA-2016-30/

https://www.phpmyadmin.net/security/PMASA-2016-31/

https://www.phpmyadmin.net/security/PMASA-2016-32/

https://www.phpmyadmin.net/security/PMASA-2016-33/

https://www.phpmyadmin.net/security/PMASA-2016-34/

https://www.phpmyadmin.net/security/PMASA-2016-35/

https://www.phpmyadmin.net/security/PMASA-2016-36/

https://www.phpmyadmin.net/security/PMASA-2016-37/

https://www.phpmyadmin.net/security/PMASA-2016-38/

https://www.phpmyadmin.net/security/PMASA-2016-39/

https://www.phpmyadmin.net/security/PMASA-2016-40/

https://www.phpmyadmin.net/security/PMASA-2016-41/

https://www.phpmyadmin.net/security/PMASA-2016-42/

https://www.phpmyadmin.net/security/PMASA-2016-43/

https://www.phpmyadmin.net/security/PMASA-2016-45/

https://www.phpmyadmin.net/security/PMASA-2016-46/

https://www.phpmyadmin.net/security/PMASA-2016-47/

https://www.phpmyadmin.net/security/PMASA-2016-48/

https://www.phpmyadmin.net/security/PMASA-2016-49/

https://www.phpmyadmin.net/security/PMASA-2016-50/

https://www.phpmyadmin.net/security/PMASA-2016-51/

https://www.phpmyadmin.net/security/PMASA-2016-52/

https://www.phpmyadmin.net/security/PMASA-2016-53/

https://www.phpmyadmin.net/security/PMASA-2016-54/

https://www.phpmyadmin.net/security/PMASA-2016-55/

https://www.phpmyadmin.net/security/PMASA-2016-56/

Plugin 詳細資訊

嚴重性: Critical

ID: 143282

檔案名稱: phpmyadmin_pmasa_4_6_4.nasl

版本: 1.3

類型: remote

系列: CGI abuses

已發布: 2020/11/30

已更新: 2020/12/1

相依性: phpMyAdmin_detect.nasl

組態: 啟用 Paranoid 模式

風險資訊

CVSS 評分資料來源: CVE-2016-6629

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: Critical

基本分數: 10

時間分數: 7.4

媒介: AV:N/AC:L/Au:N/C:C/I:C/A:C

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 8.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:phpmyadmin:phpmyadmin

必要的 KB 項目: www/PHP, installed_sw/phpMyAdmin, Settings/ParanoidReport

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2016/8/16

弱點發布日期: 2016/7/7

參考資訊

CVE: CVE-2016-6606, CVE-2016-6607, CVE-2016-6608, CVE-2016-6609, CVE-2016-6610, CVE-2016-6611, CVE-2016-6612, CVE-2016-6613, CVE-2016-6614, CVE-2016-6615, CVE-2016-6616, CVE-2016-6617, CVE-2016-6618, CVE-2016-6619, CVE-2016-6620, CVE-2016-6622, CVE-2016-6623, CVE-2016-6624, CVE-2016-6625, CVE-2016-6626, CVE-2016-6627, CVE-2016-6628, CVE-2016-6629, CVE-2016-6630, CVE-2016-6631, CVE-2016-6632, CVE-2016-6633

BID: 92489, 92490, 92491, 92492, 92493, 92494, 92496, 92497, 92500, 92501, 93257, 93258, 94112, 94113, 94114, 94115, 94117, 94118, 94366, 95041, 95042, 95044, 95047, 95048, 95049, 95052, 95055

CWE: 661