Ubuntu 20.04 LTS:Linux 核心弱點 (USN-4525-1)

high Nessus Plugin ID 140723
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

The remote Ubuntu host is missing one or more security updates.

描述

遠端 Ubuntu 20.04 LTS 主機已安裝套件,這些套件會受 USN-4525-1 公告中所提及的多個弱點影響。

- 在 5.3.9 之前的 Linux 核心內,drivers/crypto/ccp/ccp-ops.c 中的 ccp_run_sha_cmd() 函式有一個記憶體洩漏弱點,攻擊者藉此可導致拒絕服務 (記憶體消耗), 亦即 CID-128c66429247。
(CVE-2019-18808)

- 在 5.3.11 之前的 Linux 核心內,drivers/media/pci/cx23885/cx23888-ir.c 中的cx23888_ir_probe() 函式有一個記憶體洩漏弱點,攻擊者可藉由觸發 kfifo_alloc() 失敗來造成拒絕服務 (記憶體消耗),亦即 CID-a7b2df76b42b。(CVE-2019-19054)

- 在 5.6.13 之前的 Linux 核心中,VFIO PCI 驅動程式未正確處理存取已停用記憶體空間的嘗試。(CVE-2020-12888)

- 5.7.11 之前的 Linux 核心允許遠程攻擊者進行有助獲取網絡 RNG 內部狀態相關敏感資訊的觀察,亦即 CID-f227e3ec3b5c。這與 drivers/char/random.c and kernel/time/timer.c. 有關。(CVE-2020-16166)

- 在 5.8.3 之前的 Linux 核心中,本機攻擊者可以利用 NFS 用戶端程式碼中的 TOCTOU 不匹配破壞記憶體,或可能造成其他不明影響,這是因為大小檢查是在 fs/nfs/nfs4proc.c 而非 fs/nfs/nfs4xdr.c 中執行,亦即 CID-b4487b935452。(CVE-2020-25212)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

Update the affected packages.

另請參閱

https://ubuntu.com/security/notices/USN-4525-1

Plugin 詳細資訊

嚴重性: High

ID: 140723

檔案名稱: ubuntu_USN-4525-1.nasl

版本: 1.2

類型: local

代理程式: unix

已發布: 2020/9/22

已更新: 2020/11/24

相依性: ssh_get_info.nasl, linux_alt_patch_detect.nasl

風險資訊

CVSS 評分資料來源: CVE-2020-25212

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: Medium

基本分數: 4.4

時間分數: 3.3

媒介: AV:L/AC:M/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: High

基本分數: 7

時間分數: 6.1

媒介: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/o:canonical:ubuntu_linux:20.04:-:lts, p-cpe:/a:canonical:ubuntu_linux:linux-image-5.4.0-1025-gcp, p-cpe:/a:canonical:ubuntu_linux:linux-image-5.4.0-1025-oracle, p-cpe:/a:canonical:ubuntu_linux:linux-image-5.4.0-1026-azure, p-cpe:/a:canonical:ubuntu_linux:linux-image-5.4.0-48-generic, p-cpe:/a:canonical:ubuntu_linux:linux-image-5.4.0-48-generic-lpae, p-cpe:/a:canonical:ubuntu_linux:linux-image-5.4.0-48-lowlatency, p-cpe:/a:canonical:ubuntu_linux:linux-image-azure, p-cpe:/a:canonical:ubuntu_linux:linux-image-gcp, p-cpe:/a:canonical:ubuntu_linux:linux-image-generic, p-cpe:/a:canonical:ubuntu_linux:linux-image-generic-hwe-18.04, p-cpe:/a:canonical:ubuntu_linux:linux-image-generic-hwe-18.04-edge, p-cpe:/a:canonical:ubuntu_linux:linux-image-generic-hwe-20.04, p-cpe:/a:canonical:ubuntu_linux:linux-image-generic-lpae, p-cpe:/a:canonical:ubuntu_linux:linux-image-generic-lpae-hwe-18.04, p-cpe:/a:canonical:ubuntu_linux:linux-image-generic-lpae-hwe-18.04-edge, p-cpe:/a:canonical:ubuntu_linux:linux-image-generic-lpae-hwe-20.04, p-cpe:/a:canonical:ubuntu_linux:linux-image-gke, p-cpe:/a:canonical:ubuntu_linux:linux-image-lowlatency, p-cpe:/a:canonical:ubuntu_linux:linux-image-lowlatency-hwe-18.04, p-cpe:/a:canonical:ubuntu_linux:linux-image-lowlatency-hwe-18.04-edge, p-cpe:/a:canonical:ubuntu_linux:linux-image-lowlatency-hwe-20.04, p-cpe:/a:canonical:ubuntu_linux:linux-image-oem, p-cpe:/a:canonical:ubuntu_linux:linux-image-oem-osp1, p-cpe:/a:canonical:ubuntu_linux:linux-image-oracle, p-cpe:/a:canonical:ubuntu_linux:linux-image-virtual, p-cpe:/a:canonical:ubuntu_linux:linux-image-virtual-hwe-18.04, p-cpe:/a:canonical:ubuntu_linux:linux-image-virtual-hwe-18.04-edge, p-cpe:/a:canonical:ubuntu_linux:linux-image-virtual-hwe-20.04

必要的 KB 項目: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2020/9/21

弱點發布日期: 2019/11/7

參考資訊

CVE: CVE-2019-18808, CVE-2019-19054, CVE-2020-12888, CVE-2020-16166, CVE-2020-25212

USN: 4525-1