GLSA-202008-06 : iproute2: 拒絕服務

medium Nessus Plugin ID 139441

語系:

新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Gentoo 主機缺少一個或多個與安全性相關的修補程式。

描述

遠端主機受到 GLSA-202008-06 中所述的弱點影響 (iproute2:拒絕服務)

據發現,iproute2 在 ip/ipnetns.c 的 get_netnsid_from_name 中有一個釋放後使用問題。
影響:

遠端攻擊者能夠提供 iproute2 特製資料,進而可能會造成拒絕服務情形。
因應措施:

目前尚無已知的因應措施。

解決方案

所有 iproute2 使用者皆應升級至最新版本:
# emerge --sync # emerge --ask --oneshot --verbose '>=sys-apps/iproute2-5.1.0'

另請參閱

https://security.gentoo.org/glsa/202008-06

Plugin 詳細資訊

嚴重性: Medium

ID: 139441

檔案名稱: gentoo_GLSA-202008-06.nasl

版本: 1.3

類型: local

已發布: 2020/8/10

已更新: 2020/9/24

相依性: ssh_get_info.nasl

風險資訊

CVSS 評分資料來源: CVE-2019-20795

VPR

風險因素: Low

分數: 3.6

CVSS v2

風險因素: Low

基本分數: 2.1

時間分數: 1.6

媒介: CVSS2#AV:L/AC:L/Au:N/C:N/I:N/A:P

時間媒介: CVSS2#E:U/RL:OF/RC:C

CVSS v3

風險因素: Medium

基本分數: 4.4

時間分數: 3.9

媒介: CVSS:3.0/AV:L/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H

時間媒介: CVSS:3.0/E:U/RL:O/RC:C

弱點資訊

CPE: cpe:2.3:o:gentoo:linux:*:*:*:*:*:*:*:*, p-cpe:2.3:a:gentoo:linux:iproute2:*:*:*:*:*:*:*

必要的 KB 項目: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2020/8/8

弱點發布日期: 2020/5/9

參考資訊

CVE: CVE-2019-20795

GLSA: 202008-06