WordPress 外掛程式「LearnPress」< 3.2.6.8 多個弱點

high Nessus Plugin ID 136191

Synopsis

遠端 WordPress 應用程式安裝的外掛程式容易受到多個弱點影響。

描述

遠端主機上執行的 WordPress 應用程式具有版本早於 3.2.6.8 版的「LearnPress」外掛程式,因此會受到多個弱點影響:

- LP_Modal_Search_Items 類別的 _get_items 方法中存在 SQL 插入 (SQLi) 弱點,這是未充分驗證使用者提供的輸入所致。經驗證的遠端攻擊者可利用此弱點,在後端資料庫中插入或操控 SQL 查詢,進而導致洩漏或操控任意資料。(CVE-2020-6010)

- learn_press_accept_become_a_teacher 函式中存在權限提升弱點,這是程式碼未檢查要求使用者的權限所致。未經驗證的遠端攻擊者可利用此弱點,透過 /wpadmin/ 取得應用程式的「teacher」存取權。(CVE-2020-11511)

請注意,Nessus 並未嘗試利用這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

透過系統管理儀表板,將「LearnPress」外掛程式更新至 3.2.6.8 版或更新版本。

另請參閱

http://www.nessus.org/u?b38b6cba

https://wordpress.org/plugins/learnpress/#developers

Plugin 詳細資訊

嚴重性: High

ID: 136191

檔案名稱: wordpress_plugin_learnpress_3_2_6_8.nasl

版本: 1.5

類型: remote

系列: CGI abuses

已發布: 2020/5/1

已更新: 2022/5/13

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: Medium

基本分數: 6.8

時間分數: 5.3

媒介: AV:N/AC:M/Au:N/C:P/I:P/A:P

時間媒介: E:POC/RL:OF/RC:C

CVSS 評分資料來源: CVE-2020-11511

CVSS v3

風險因素: High

基本分數: 8.8

時間分數: 7.9

媒介: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:P/RL:O/RC:C

CVSS 評分資料來源: CVE-2020-6010

弱點資訊

CPE: cpe:/a:wordpress:wordpress

必要的 KB 項目: installed_sw/WordPress, www/PHP

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2020/3/30

弱點發布日期: 2020/3/30

參考資訊

CVE: CVE-2020-6010, CVE-2020-11511