Apache 2.4.x < 2.4.42 多個弱點

medium Nessus Plugin ID 135290

Synopsis

遠端 Web 伺服器受到多個弱點影響。

描述

遠端主機上安裝的 Apache httpd 版本早於 2.4.42。因此,會受到 2.4.42 公告中所提及的多個弱點影響。

- 在 Apache HTTP Server 2.4.0 至 2.4.41 中,mod_proxy_ftp 在代理惡意 FTP 伺服器時可能使用未初始化的記憶體。(CVE-2020-1934)

- 在 Apache HTTP Server 2.4.0 至 2.4.41 中,以 mod_rewrite 設定的重新導向 (原用於自我參照) 可能會遭到編碼的新行誘騙,而重新導向至要求 URL 內的非預期 URL。(CVE-2020-1927)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 Apache 2.4.42 或更新版本。

Plugin 詳細資訊

嚴重性: Medium

ID: 135290

檔案名稱: apache_2_4_42.nasl

版本: 1.9

類型: combined

代理程式: windows, macosx, unix

系列: Web Servers

已發布: 2020/4/10

已更新: 2022/12/5

組態: 啟用徹底檢查

支持的傳感器: Nessus Agent

風險資訊

VPR

風險因素: Medium

分數: 4.6

CVSS v2

風險因素: Medium

基本分數: 5.8

時間分數: 4.3

媒介: AV:N/AC:M/Au:N/C:P/I:P/A:N

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2020-1927

CVSS v3

風險因素: Medium

基本分數: 6.1

時間分數: 5.3

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:apache:httpd, cpe:/a:apache:http_server

必要的 KB 項目: installed_sw/Apache

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2020/4/1

弱點發布日期: 2020/4/1

參考資訊

CVE: CVE-2020-1927, CVE-2020-1934

IAVA: 2020-A-0129-S

CEA-ID: CEA-2021-0025