3S CODESYS Runtime 3.x < 3.5.14.20 多個弱點

critical Nessus Plugin ID 134977

概要

A programmable logic controller (PLC) runtime on the remote host is affected by multiple vulnerabilities.

說明

遠端主機上的 3S CODESYS 執行階段環境受到多個弱點影響:

- CODESYS 閘道未正確驗證通訊通道的擁有權。(CVE-2019-9010)

- 特製的通訊要求可能會在受影響的 CODESYS 產品中造成不受控制的記憶體配置,並可能導致拒絕服務情形。(CVE-2019-9012)

- 應用程式可能利用非 TLS 型加密,進而導致在傳輸期間未充分保護使用者憑證。(CVE-2019-9013)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

Upgrade 3S CODESYS Runtime to version 3.5.14.20 or higher.

另請參閱

http://www.nessus.org/u?d4b9ab01

http://www.nessus.org/u?167a4fa1

Plugin 詳細資訊

嚴重性: Critical

ID: 134977

檔案名稱: scada_codesys_runtime_3_5_14_20.nbin

版本: 1.57

類型: remote

系列: SCADA

已發布: 2020/3/30

已更新: 2024/7/17

組態: 啟用徹底檢查

支援的感應器: Nessus

風險資訊

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.5

媒介: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS 評分資料來源: CVE-2019-9010

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 8.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: CVSS:3.0/E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:3s-software:codesys_runtime_system

必要的 KB 項目: SCADA/CoDeSys

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2019/8/1

弱點發布日期: 2019/8/1

參考資訊

CVE: CVE-2019-9010, CVE-2019-9012, CVE-2019-9013

IAVA: 2019-A-0275