PHP 7.3.x < 7.3.16 多個弱點

high Nessus Plugin ID 134944

Synopsis

遠端 Web 伺服器上執行的 PHP 版本受到多個弱點影響。

描述

根據其標題,遠端 Web 伺服器上執行的 PHP 版本為 7.3.16 之前的 7.3.x 版。因此受到以下弱點影響:

- 越界讀取,導致在 exif 中使用未初始化值 (CVE-2020-7064)

- 其中的堆疊型緩衝區溢位允許使用 .rodata 中的溢位陣列覆寫堆疊配置的緩衝區。(CVE-2020-7065)

- get_headers() 以無訊息模式截斷其使用的 URL NULL 位元組後的所有內容。未經驗證的遠端攻擊者可利用此弱點洩漏敏感資訊,或使 Web 伺服器意外處理攻擊者控制的資料。(CVE-2020-7066) 請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 PHP 7.3.16 版或更新版本。

另請參閱

https://www.php.net/ChangeLog-7.php#7.3.16

Plugin 詳細資訊

嚴重性: High

ID: 134944

檔案名稱: php_7_3_16.nasl

版本: 1.5

類型: remote

系列: CGI abuses

已發布: 2020/3/27

已更新: 2022/4/11

組態: 啟用徹底檢查

風險資訊

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: Medium

基本分數: 6.8

時間分數: 5

媒介: AV:N/AC:M/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2020-7065

CVSS v3

風險因素: High

基本分數: 8.8

時間分數: 7.7

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP, installed_sw/PHP

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2020/3/19

弱點發布日期: 2020/3/19

參考資訊

CVE: CVE-2020-7064, CVE-2020-7065, CVE-2020-7066

IAVA: 2020-A-0117-S