EulerOS 2.0 SP2:giflib (EulerOS-SA-2019-2498)

medium Nessus Plugin ID 131651
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 EulerOS 主機缺少多個安全性更新。

描述

根據安裝的 giflib 套件版本,遠端主機上的 EulerOS 安裝會受到下列弱點影響:- 在 GIFLIB 2019-02-16 之前的版本中,若 ImageSize 資料結構的高度欄位等於零,則格式錯誤的 GIF 檔案可在 dgif_lib.c 的 decoder 函式 DGifSlurp 中觸發除以零例外狀況。(CVE-2019-15133) - 在 giflib 5.1.1 中,giffix 之 giffix.c 中的堆積型緩衝區溢位,可讓攻擊者透過特製的影像和 GIF 檔案中的邏輯畫面寬度欄位造成拒絕服務 (程式損毀)。(CVE-2015-7555) - 在 giflib 5.1.2 中,gif2rgb 之 util/gif2rgb.c 中的堆積型緩衝區溢位,可讓遠端攻擊者透過 GIF 檔案中的背景色彩索引造成拒絕服務 (應用程式損毀)。(CVE-2016-3977) 請注意,Tenable Network Security 已直接從 EulerOS 安全性公告擷取前置描述區塊。Tenable 已盡量在不造成其他問題的前提下,嘗試自動清理並將其格式化。

解決方案

更新受影響的 giflib 套件。

另請參閱

http://www.nessus.org/u?9cf375ef

Plugin 詳細資訊

嚴重性: Medium

ID: 131651

檔案名稱: EulerOS_SA-2019-2498.nasl

版本: 1.5

類型: local

已發布: 2019/12/4

已更新: 2021/1/6

相依性: ssh_get_info.nasl

風險資訊

CVSS 評分資料來源: CVE-2019-15133

VPR

風險因素: Low

分數: 3.6

CVSS v2

風險因素: Medium

基本分數: 4.3

時間分數: 3.2

媒介: AV:N/AC:M/Au:N/C:N/I:N/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: Medium

基本分數: 6.5

時間分數: 5.7

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:huawei:euleros:giflib, cpe:/o:huawei:euleros:2.0

必要的 KB 項目: Host/local_checks_enabled, Host/EulerOS/release, Host/EulerOS/rpm-list, Host/EulerOS/sp

排除在外的 KB 項目: Host/EulerOS/uvp_version

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2019/12/4

參考資訊

CVE: CVE-2015-7555, CVE-2016-3977, CVE-2019-15133