EulerOS 2.0 SP2:libtar (EulerOS-SA-2019-2444)

medium Nessus Plugin ID 131598

概要

遠端 EulerOS 主機缺少安全性更新。

描述

根據安裝的 libtar 套件版本,遠端主機上的 EulerOS 安裝會受到下列弱點影響:- 在 libtar 1.2.20 和更舊版本中,(1) tar_extract_glob 和 (2) tar_extract_all 函式中的多個目錄遊走弱點允許遠端攻擊者透過特製 tar 檔案中的 ..(點點),覆寫任意檔案。(CVE-2013-4420) 請注意,Tenable Network Security 已直接從 EulerOS 安全性公告擷取前置描述區塊。Tenable 已盡量在不造成其他問題的前提下,嘗試自動清理並將其格式化。

解決方案

更新受影響的 libtar 套件。

另請參閱

http://www.nessus.org/u?600bd359

Plugin 詳細資訊

嚴重性: Medium

ID: 131598

檔案名稱: EulerOS_SA-2019-2444.nasl

版本: 1.5

類型: local

發布日期: 2019/12/4

更新日期: 2021/1/6

風險資訊

VPR

風險因素: Medium

分數: 4.0

CVSS v2

風險因素: Medium

基本分數: 5.8

時間分數: 4.3

媒介: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:P

時間媒介: CVSS2#E:U/RL:OF/RC:ND

弱點資訊

CPE: p-cpe:/a:huawei:euleros:libtar, cpe:/o:huawei:euleros:2.0

必要的 KB 項目: Host/local_checks_enabled, Host/EulerOS/release, Host/EulerOS/rpm-list, Host/EulerOS/sp

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2019/12/4

參考資訊

CVE: CVE-2013-4420

BID: 62955