Debian DSA-4529-1:php7.0 - 安全性更新

critical Nessus Plugin ID 129107

語系:

新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Debian 主機缺少安全性更新。

描述

在 PHP (一種廣泛使用的開放原始碼一般用途指令碼語言) 中發現多個安全性問題:EXIF 延伸模組和 iconv_mime_decode_headers() 函式缺少清理,可會導致資訊洩漏或拒絕服務。

解決方案

升級 php7.0 套件。針對舊的穩定發行版本 (stretch),這些問題已在 7.0.33-0+deb9u5 版本中修正。

另請參閱

https://security-tracker.debian.org/tracker/source-package/php7.0

https://packages.debian.org/source/stretch/php7.0

https://www.debian.org/security/2019/dsa-4529

Plugin 詳細資訊

嚴重性: Critical

ID: 129107

檔案名稱: debian_DSA-4529.nasl

版本: 1.3

類型: local

代理程式: unix

已發布: 2019/9/23

已更新: 2019/12/27

相依性: ssh_get_info.nasl

風險資訊

VPR

風險因素: Medium

分數: 6

CVSS v2

風險因素: Medium

基本分數: 6.4

時間分數: 4.7

媒介: AV:N/AC:L/Au:N/C:P/I:N/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: Critical

基本分數: 9.1

時間分數: 7.9

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:debian:debian_linux:php7.0, cpe:/o:debian:debian_linux:9.0

必要的 KB 項目: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2019/9/20

弱點發布日期: 2019/4/18

參考資訊

CVE: CVE-2019-11034, CVE-2019-11035, CVE-2019-11036, CVE-2019-11038, CVE-2019-11039, CVE-2019-11040, CVE-2019-11041, CVE-2019-11042

DSA: 4529