Apache Struts 2.0.x < 2.0.12 / 2.1.x < 2.1.6 目錄遊走弱點 (S2-004)

medium Nessus Plugin ID 128766

Synopsis

遠端主機上執行的 Web 應用程式使用受到目錄遊走弱點影響的 Java 框架。

描述

遠端主機上執行的 Apache Struts 版本是比 2.0.12 舊的 2.0.x 版,或比 2.1.6 舊的 2.1.x 版。因此,會受到 FilterDispatcher (2.0 中) 和 DefaultStaticContentLoader (2.1 中) 中一個目錄遊走弱點影響,這是因為限制不充份所致。未經驗證的遠端攻擊者可惡意利用此弱點,藉此遊走目錄結構並下載任意檔案。請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 Apache Struts 2.0.12 / 2.1.6 版或更新版本

另請參閱

https://cwiki.apache.org/confluence/display/WW/S2-004

Plugin 詳細資訊

嚴重性: Medium

ID: 128766

檔案名稱: struts_2_1_6.nasl

版本: 1.4

類型: combined

代理程式: windows, macosx, unix

系列: Misc.

已發布: 2019/9/13

已更新: 2022/4/11

組態: 啟用徹底檢查

支持的傳感器: Frictionless Assessment Agent, Nessus Agent

風險資訊

CVSS 評分論據: Directory traversal

CVSS v2

風險因素: Medium

基本分數: 5

媒介: AV:N/AC:L/Au:N/C:P/I:N/A:N

CVSS 評分資料來源: manual

CVSS v3

風險因素: Medium

基本分數: 5.3

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

弱點資訊

CPE: cpe:/a:apache:struts

修補程式發佈日期: 2007/6/22

弱點發布日期: 2008/6/22