Ubuntu 16.04 LTS / 18.04 LTS:Tomcat 弱點 (USN-4128-1)

medium Nessus Plugin ID 128682

Synopsis

遠端 Ubuntu 主機缺少一個或多個安全性相關修補程式。

描述

據發現, Tomcat 8 SSI printenv 命令會回應使用者提供的資料而不逸出。攻擊者可能利用此問題發動 XSS 攻擊。(CVE-2019-0221) 據發現,Tomcat 8 未在處理 CVE-2019-0199 時,解決寫入時的 HTTP/2 連線視窗耗盡問題。攻擊者可能利用此問題造成拒絕服務。(CVE-2019-10072). 請注意,Tenable Network Security 已直接從 Ubuntu 安全性公告擷取前置描述區塊。Tenable 已盡量在不造成其他問題的前提下,嘗試自動清理並將其格式化。

解決方案

更新受影響的 libtomcat8-java 和/或 tomcat8 套件。

另請參閱

https://usn.ubuntu.com/4128-1/

Plugin 詳細資訊

嚴重性: Medium

ID: 128682

檔案名稱: ubuntu_USN-4128-1.nasl

版本: 1.5

類型: local

代理程式: unix

已發布: 2019/9/11

已更新: 2022/12/5

支持的傳感器: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

風險資訊

VPR

風險因素: Medium

分數: 5.1

CVSS v2

風險因素: Medium

基本分數: 4.3

時間分數: 3.4

媒介: AV:N/AC:M/Au:N/C:N/I:P/A:N

時間媒介: E:POC/RL:OF/RC:C

CVSS 評分資料來源: CVE-2019-0221

CVSS v3

風險因素: Medium

基本分數: 6.1

時間分數: 5.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

時間媒介: E:P/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:canonical:ubuntu_linux:libtomcat8-java, p-cpe:/a:canonical:ubuntu_linux:tomcat8, cpe:/o:canonical:ubuntu_linux:16.04, cpe:/o:canonical:ubuntu_linux:18.04:-:lts

必要的 KB 項目: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2019/9/10

弱點發布日期: 2019/4/10

參考資訊

CVE: CVE-2019-0199, CVE-2019-0221, CVE-2019-10072

USN: 4128-1

CEA-ID: CEA-2021-0025