CentOS 7:python-requests (CESA-2019:2035)

high Nessus Plugin ID 128335

概要

遠端 CentOS 主機缺少安全性更新。

說明

現已提供適用於 Red Hat Enterprise Linux 7 的 python-requests 更新。Red Hat 產品安全性團隊已將此更新評等為具有低安全性影響。可從〈參照〉一節的 CVE 連結中取得每個弱點之常見弱點評分系統 (CVSS) 的基本分數,其中包含有關嚴重性評等的詳細資訊。python-requests 套件所含的程式庫專為便於開發人員提出 HTTP 要求而設計。安全性修正:* python-requests:從 HTTPS 重新導向到 HTTP 不會移除授權標頭 (CVE-2018-18074) 如需安全性問題的詳細資料,包括影響、CVSS 分數、致謝及其他相關資訊,請參閱〈參照〉一節列出的 CVE 頁面。其他變更:如需有關此發行版本的詳細變更資訊,請參閱可從〈參照〉一節連結的 Red Hat Enterprise Linux 7.7 版本資訊。

解決方案

更新受影響的 python-requests 套件。

另請參閱

http://www.nessus.org/u?381c8e44

Plugin 詳細資訊

嚴重性: High

ID: 128335

檔案名稱: centos_RHSA-2019-2035.nasl

版本: 1.4

類型: local

代理程式: unix

已發布: 2019/8/30

已更新: 2021/4/16

支援的感應器: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Agentless Assessment, Nessus

風險資訊

VPR

風險因素: Medium

分數: 4.4

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 3.7

媒介: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

CVSS 評分資料來源: CVE-2018-18074

CVSS v3

風險因素: High

基本分數: 7.5

時間分數: 6.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

時間媒介: CVSS:3.0/E:U/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:centos:centos:python-requests, cpe:/o:centos:centos:7

必要的 KB 項目: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2019/8/30

弱點發布日期: 2018/10/9

參考資訊

CVE: CVE-2018-18074

RHSA: 2019:2035