Exim < 4.92.1 輸入驗證 RCE

critical Nessus Plugin ID 128036

Synopsis

遠端郵件伺服器可能會受到一個遠端程式碼執行弱點影響。

描述

根據其標題,遠端主機上執行的 Exim 版本比 4.92.1 舊。因此可能會受到 ‘${sort }’ 擴充中的輸入驗證缺陷影響。遠端攻擊者可能會執行任意程式碼。請注意,預設組態不包含 ‘${sort }’。

解決方案

升級至 Exim 4.92.1 或更新版本。

另請參閱

https://exim.org/static/doc/security/CVE-2019-13917.txt

https://ftp.exim.org/pub/exim/exim4/ChangeLog

Plugin 詳細資訊

嚴重性: Critical

ID: 128036

檔案名稱: exim_4_92_1.nasl

版本: 1.3

類型: remote

已發布: 2019/8/20

已更新: 2019/10/17

組態: 啟用 Paranoid 模式

風險資訊

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: Critical

基本分數: 10

時間分數: 7.4

媒介: AV:N/AC:L/Au:N/C:C/I:C/A:C

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2019-13917

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 8.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:exim:exim

必要的 KB 項目: Settings/ParanoidReport

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2019/7/18

弱點發布日期: 2019/7/18

參考資訊

CVE: CVE-2019-13917

BID: 109338