Apache 2.4.x < 2.4.41 多個弱點

critical Nessus Plugin ID 128033

Synopsis

遠端 Web 伺服器受到多個弱點影響。

描述

遠端主機上安裝的 Apache httpd 版本早於 2.4.41。因此,該軟體受到 2.4.41 公告中所提及的多個弱點影響,包括下列項目:

- 據報告,存在跨網站指令碼問題,可影響 mod_proxy 錯誤頁面。攻擊者可造成錯誤頁面上的連結格式錯誤,使連結指向其選擇的頁面。只有在伺服器設定為啟用代理,但因配置不當而顯示「代理錯誤」頁面時,才可利用此漏洞。(CVE-2019-10092)

- HTTP/2 (2.4.20 到 2.4.39) 非常早期的推送 (例如,使用 H2PushResource 組態) 可導致在推送要求的集區中覆寫記憶體,進而導致當機。複製的是組態之推送連結標頭值的記憶體,而非用戶端提供的資料。(CVE-2019-10081)

- 部分 HTTP/2 實作容易受到不受限制的內部資料緩衝影響,進而可能導致拒絕服務。攻擊者會開啟 HTTP/2 視窗,使對等端可以不受限制地傳送;
但是它們會關閉 TCP 視窗,這樣對等端在連線時,就無法實際寫入 (許多) 位元組。接著,攻擊者會針對大型回應物件傳送要求串流。根據伺服器佇列回應的方式,這可能會消耗過量的記憶體或 CPU,或是兩者都過度消耗。(CVE-2019-9517)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 Apache 2.4.41 或更新版本。

Plugin 詳細資訊

嚴重性: Critical

ID: 128033

檔案名稱: apache_2_4_41.nasl

版本: 1.13

類型: combined

代理程式: windows, macosx, unix

系列: Web Servers

已發布: 2019/8/20

已更新: 2022/12/5

組態: 啟用徹底檢查

支持的傳感器: Nessus Agent

風險資訊

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: Medium

基本分數: 6.4

時間分數: 5

媒介: AV:N/AC:L/Au:N/C:P/I:N/A:P

時間媒介: E:POC/RL:OF/RC:C

CVSS 評分資料來源: CVE-2019-10082

CVSS v3

風險因素: Critical

基本分數: 9.1

時間分數: 8.2

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

時間媒介: E:P/RL:O/RC:C

弱點資訊

CPE: cpe:/a:apache:httpd, cpe:/a:apache:http_server

必要的 KB 項目: installed_sw/Apache

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2019/8/14

弱點發布日期: 2019/8/13

參考資訊

CVE: CVE-2019-9517, CVE-2019-10081, CVE-2019-10082, CVE-2019-10092, CVE-2019-10097, CVE-2019-10098

CEA-ID: CEA-2019-0643