NewStart CGSL MAIN 4.05:samba 多個弱點 (NS-SA-2019-0096)

critical Nessus Plugin ID 127320

語系:

Synopsis

遠端機器受到多個弱點的影響。

描述

執行 MAIN 4.05 版的遠端 NewStart CGSL 主機安裝了受多個弱點影響的 samba 套件:- 在 Samba 處理 PAC (專用權屬性憑證) 總和檢查碼的方式中,發現一個缺陷。經過驗證的遠端攻擊者可利用此缺陷造成 winbindd 處理程序損毀。(CVE-2016-2126) - 據發現,使用 Kerberos 驗證時,Samba 始終要求可轉發的票證。Samba 使用 Kerberos 驗證的服務,後續可能使用該票證將 Samba 模擬到其他服務或網域使用者。(CVE-2016-2125) - 在 Samba 中發現一個遠端程式碼執行缺陷。對 samba 共用具有寫入存取權限的惡意經驗證用戶端可利用此缺陷,以 root 身分執行任意程式碼。(CVE-2017-7494) 請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級易受弱點影響的 CGSL samba 套件。請注意,可能尚未出爐已升級的套件。如需詳細資訊,請聯絡 ZTE。

另請參閱

http://security.gd-linux.com/notice/NS-SA-2019-0096

Plugin 詳細資訊

嚴重性: Critical

ID: 127320

檔案名稱: newstart_cgsl_NS-SA-2019-0096_samba.nasl

版本: 1.5

類型: local

已發布: 2019/8/12

已更新: 2021/1/14

風險資訊

CVSS 評分資料來源: CVE-2017-7494

VPR

風險因素: Critical

分數: 9.5

CVSS v2

風險因素: Critical

基本分數: 10

時間分數: 8.3

媒介: AV:N/AC:L/Au:N/C:C/I:C/A:C

時間媒介: E:F/RL:OF/RC:C

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 9.1

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:F/RL:O/RC:C

弱點資訊

必要的 KB 項目: Host/local_checks_enabled, Host/ZTE-CGSL/release, Host/ZTE-CGSL/rpm-list, Host/cpu

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2019/7/17

弱點發布日期: 2017/5/11

惡意利用途徑

CANVAS (CANVAS)

Core Impact

Metasploit (Samba is_known_pipename() Arbitrary Module Load)

參考資訊

CVE: CVE-2016-2125, CVE-2016-2126, CVE-2017-7494