NewStart CGSL CORE 5.04 / MAIN 5.04:php 多個弱點 (NS-SA-2019-0019)

medium Nessus Plugin ID 127174

語系:

新推出!弱點優先順序評分 (VPR)

Tenable 會為每個弱點計算動態 VPR。VPR 將弱點資訊與威脅情報和機器學習演算法加以結合,藉此預測攻擊者最有可能利用哪些弱點發動攻擊。查看詳細資訊: VPR 是什麼?它跟 CVSS 有何不同?

VPR 評分: 5.9

Synopsis

遠端機器受到多個弱點的影響。

描述

執行 CORE 5.04 / MAIN 5.04 版的遠端 NewStart CGSL 主機安裝了受多個弱點影響的 php 套件:- 在 libgd 讀取某些特製的 gd2 檔案的方式中發現整數溢位缺陷,導致堆積型緩衝區溢位。遠端攻擊者可利用此缺陷,造成使用 libgd 編譯的應用程式損毀,或在某些情況下,以執行該應用程式的使用者權限來執行任意程式碼。(CVE-2016-10168) - 在 libgd 中發現 null 指標解除參照缺陷。攻擊者可利用特製的 .gd2 檔案造成與 libgd 連結的應用程式損毀,進而導致拒絕服務。(CVE-2016-10167) - 在 PHP 5.6.31 和 7.1.7 之前的版本中,發現 GD 圖庫的 gdImageCreateFromGifCtx() 中有資料洩漏問題。攻擊者可特製惡意的 GIF 影像並從堆疊中讀取多達 762 位元組。(CVE-2017-7890) 請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級易受弱點影響的 CGSL php 套件。請注意,可能尚未出爐已升級的套件。如需詳細資訊,請聯絡 ZTE。

另請參閱

http://security.gd-linux.com/notice/NS-SA-2019-0019

Plugin 詳細資訊

嚴重性: Medium

ID: 127174

檔案名稱: newstart_cgsl_NS-SA-2019-0019_php.nasl

版本: 1.4

類型: local

已發布: 2019/8/12

已更新: 2021/1/14

相依性: ssh_get_info.nasl

風險資訊

風險因素: Medium

VPR 評分: 5.9

CVSS 評分資料來源: CVE-2016-10168

CVSS v2.0

基本分數: 6.8

時間分數: 5

媒介: AV:N/AC:M/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS v3.0

基本分數: 7.8

時間分數: 6.8

媒介: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

必要的 KB 項目: Host/local_checks_enabled, Host/ZTE-CGSL/release, Host/ZTE-CGSL/rpm-list, Host/cpu

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2019/7/17

弱點發布日期: 2017/3/15

參考資訊

CVE: CVE-2016-10167, CVE-2016-10168, CVE-2017-7890