Apache ZooKeeper < 3.4.14 / 3.5.x < 3.5.5 資訊洩漏

medium Nessus Plugin ID 125635
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Apache ZooKeeper 服務器受到一個資訊洩漏弱點的影響。

描述

遠端主機上執行的 Apache ZooKeeper 版本為 3.4.14 之前版本或 3.5.5 之前的 3.5.x 版。因此,會受到 ZooKeeper 的 getACL() 命令中一個資訊洩漏弱點影響,這是因為未檢查要求者權限所致。未經驗證的遠端攻擊者可加以惡意利用來洩漏可能的敏感資訊。

解決方案

升級至 Apache ZooKeeper 3.4.14、3.5.5 或更新版本。

另請參閱

https://zookeeper.apache.org/security.html

https://issues.apache.org/jira/browse/ZOOKEEPER-1392

Plugin 詳細資訊

嚴重性: Medium

ID: 125635

檔案名稱: apache_zookeeper_3_5_5.nasl

版本: 1.2

類型: combined

系列: Misc.

已發布: 2019/5/31

已更新: 2019/10/18

相依性: apache_zookeeper_detect.nasl

組態: 啟用 Paranoid 模式

風險資訊

CVSS 評分資料來源: CVE-2019-0201

VPR

風險因素: Low

分數: 3.6

CVSS v2

風險因素: Medium

基本分數: 4.3

時間分數: 3.2

媒介: AV:N/AC:M/Au:N/C:P/I:N/A:N

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: Medium

基本分數: 5.9

時間分數: 5.2

媒介: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:apache:zookeeper

必要的 KB 項目: Settings/ParanoidReport

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2019/5/23

弱點發布日期: 2019/5/23

參考資訊

CVE: CVE-2019-0201

BID: 104253

IAVB: 2019-B-0041