RHEL 6:java-1.8.0-ibm (RHSA-2019:1163)

high Nessus Plugin ID 125012

Synopsis

遠端 Red Hat 主機缺少一個或多個安全性更新。

描述

現已提供適用於 Red Hat Enterprise Linux 6 Supplementary 的 java-1.8.0-ibm 更新。Red Hat 產品安全性團隊已將此更新評等為具有重要安全性影響。可從〈參照〉一節的 CVE 連結中取得每個弱點之常見弱點評分系統 (CVSS) 的基本分數,其中包含有關嚴重性評等的詳細資訊。IBM Java SE 版本 8 包含 IBM Java Runtime Environment 和 IBM Java Software Development Kit。此更新會將 IBM Java SE 8 升級至 8 SR5-FP35 版。安全性修正:* Oracle JDK:已修正 7u221 和 8u211 中的不明弱點 (2D) (CVE-2019-2697) * OpenJDK:字型配置引擎超出邊界存取 setCurrGlyphID() (2D,8219022) (CVE-2019-2698) * OpenJDK:從 BigDecimal 到 long (程式庫,8211936) 的緩慢轉換 (CVE-2019-2602) * OpenJDK:在 RMI 登錄伺服器端分派處理中選取錯誤的骨架 (RMI,8218453) (CVE-2019-2684) * IBM JDK:讀取超過位元組程式碼陣列末端的部分導致 JVM 損毀 (CVE-2019-10245) 如需安全性問題的詳細資料,包括影響、CVSS 分數、致謝及其他相關資訊,請參閱〈參照〉一節列出的 CVE 頁面。

解決方案

更新受影響的套件。

另請參閱

https://access.redhat.com/errata/RHSA-2019:1163

https://access.redhat.com/security/cve/cve-2019-2602

https://access.redhat.com/security/cve/cve-2019-2684

https://access.redhat.com/security/cve/cve-2019-2697

https://access.redhat.com/security/cve/cve-2019-2698

https://access.redhat.com/security/cve/cve-2019-10245

Plugin 詳細資訊

嚴重性: High

ID: 125012

檔案名稱: redhat-RHSA-2019-1163.nasl

版本: 1.5

類型: local

代理程式: unix

已發布: 2019/5/14

已更新: 2019/10/24

支持的傳感器: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: Medium

基本分數: 6.8

時間分數: 5.3

媒介: AV:N/AC:M/Au:N/C:P/I:P/A:P

時間媒介: E:POC/RL:OF/RC:C

CVSS v3

風險因素: High

基本分數: 8.1

時間分數: 7.3

媒介: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:P/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:redhat:enterprise_linux:java-1.8.0-ibm, p-cpe:/a:redhat:enterprise_linux:java-1.8.0-ibm-demo, p-cpe:/a:redhat:enterprise_linux:java-1.8.0-ibm-devel, p-cpe:/a:redhat:enterprise_linux:java-1.8.0-ibm-jdbc, p-cpe:/a:redhat:enterprise_linux:java-1.8.0-ibm-plugin, p-cpe:/a:redhat:enterprise_linux:java-1.8.0-ibm-src, cpe:/o:redhat:enterprise_linux:6

必要的 KB 項目: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2019/5/13

弱點發布日期: 2019/4/19

參考資訊

CVE: CVE-2019-10245, CVE-2019-2602, CVE-2019-2684, CVE-2019-2697, CVE-2019-2698

RHSA: 2019:1163