OracleVM 3.4:Unbreakable /等 (OVMSA-2019-0007) (Spectre)

medium Nessus Plugin ID 122087
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 OracleVM 主機缺少一個或多個安全性更新。

描述

遠端 OracleVM 系統缺少可解決重大安全性更新的必要修補程式:

- x86/錯誤:修復 SPEC_CTRL MSR 的 AMD SSBD 使用 (Tom Lendacky) [Orabug:28870524] (CVE-2018-3639)

- x86/錯誤:新增 AMD 的 SPEC_CTRL MSR 使用 (Konrad Rzeszutek Wilk) [Orabug:28870524] (CVE-2018-3639)

- x86/cpufeatures:將 X86_FEATURE_AMD_SSBD 重新命名為 X86_FEATURE_LS_CFG_SSBD (Mihai Carabas) [Orabug:
28870524] (CVE-2018-3639)

- 使檔案憑證可用於 seqfile 介面 (Linus Torvalds) [Orabug:29114879] (CVE-2018-17972)

- proc:將核心堆疊轉儲存限制為 root (Jann Horn) [Orabug:29114879] (CVE-2018-17972)

- x86/推測:清理 bugs.c 中的 retpoline 程式碼 (Alejandro Jimenez) [Orabug:29211617]

- x86、modpost:使用 CONFIG_RETPOLINE 取代 RETPOLINE 的剩餘殘留項 (WANG Chao) [Orabug:29211617]

- x86/構建:修復 CONFIG_RETPOLINE 的編譯器支援檢查 (Masahiro Yamada) [Orabug:29211617]

- x86/retpoline:移除最低限度的 retpoline 支援 (Zhenzhong Duan) [Orabug:29211617]

- x86/retpoline:使 CONFIG_RETPOLINE 依賴編譯器支援 (Zhenzhong Duan) [Orabug:29211617]

- nl80211:檢查所需的 netlink 屬性是否存在 (Vladis Dronov) [Orabug:29245533] (CVE-2017-12153) (CVE-2017-12153)

- scsi:lpfc:修復 PT2PT PRLI 拒絕 (重新套用修補程式) (James Smart) [Orabug:29281346]

解決方案

更新受影響的 kernel-uek / kernel-uek-firmware 套件。

另請參閱

http://www.nessus.org/u?66ac1732

Plugin 詳細資訊

嚴重性: Medium

ID: 122087

檔案名稱: oraclevm_OVMSA-2019-0007.nasl

版本: 1.4

類型: local

已發布: 2019/2/11

已更新: 2020/2/12

相依性: ssh_get_info.nasl

風險資訊

CVSS 評分資料來源: CVE-2018-3639

VPR

風險因素: Medium

分數: 5.1

CVSS v2

風險因素: Medium

基本分數: 4.9

時間分數: 3.8

媒介: AV:L/AC:L/Au:N/C:C/I:N/A:N

時間媒介: E:POC/RL:OF/RC:C

CVSS v3

風險因素: Medium

基本分數: 5.5

時間分數: 5

媒介: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

時間媒介: E:P/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:oracle:vm:kernel-uek, p-cpe:/a:oracle:vm:kernel-uek-firmware, cpe:/o:oracle:vm_server:3.4

必要的 KB 項目: Host/local_checks_enabled, Host/OracleVM/release, Host/OracleVM/rpm-list

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2019/2/8

弱點發布日期: 2017/9/21

參考資訊

CVE: CVE-2017-12153, CVE-2018-17972, CVE-2018-3639