PHP 5.6.x < 5.6.40 多個弱點。

critical Nessus Plugin ID 121602
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端主機上安裝的應用程式受到多個弱點影響。

描述

根據其標題,遠端網頁伺服器上執行的 PHP 版本為 5.6.40 之前的 5.6.x 版。因此受到多個弱點影響:- 在 gd_interpolation.c 的 _gdContributionsAlloc 函式中存在一個整數反向溢位情形。未經驗證的遠端攻擊者可透過與遞減 u 變數相關的向量,造成不明的影響。(CVE-2016-10166) - gdImageColorMatch 中存在一個堆積型緩衝區溢位情形,這是因為不當計算配置的緩衝區大小所致。攻擊者可惡意利用此弱點,透過呼叫 imagecolormatch 函式,並以特製影像資料作為參數。(CVE-2019-6977) - xmlrpc_decode 函式中有堆積緩衝區過度讀取情形,這是因為不當驗證輸入資料所致。未經驗證的遠端攻擊者可加以惡意利用,透過特製的要求造成堆積超出邊界讀取或釋放後讀取情形,進而可能導致系統全面遭到入侵。(CVE-2019-9020) - PHAR 延伸模組的 PHAR 讀取函式中有堆積型緩衝區過度讀取情形,這是因為不當實作記憶體作業所致。未經驗證的遠端攻擊者可加以惡意利用,透過誘騙使用者在目標系統上剖析特製的檔案名稱,來洩漏敏感資訊。(CVE-2019-9021) - mbstring 規則運算式函式中有多個堆積型緩衝區過度讀取執行個體,這是因為不當實作記憶體作業所致。未經驗證的遠端攻擊者可傳送含有多位元組序列的特製規則運算式來加以惡意利用,以造成允許攻擊者全面入侵目標系統的情形。(CVE-2019-9023) - xmlrpc_decode 函式中有一個超出邊界讀取錯誤,這是因為不當實作記憶體作業所致。未經驗證的遠端攻擊者可加以惡意利用,透過惡意的 XMLRPC 伺服器造成 PHP 從已配置區域之外的記憶體讀取。(CVE-2019-9024)

解決方案

升級為 PHP 5.6.40 或更新版本。

另請參閱

http://php.net/ChangeLog-5.php#5.6.40

Plugin 詳細資訊

嚴重性: Critical

ID: 121602

檔案名稱: php_5_6_40.nasl

版本: 1.5

類型: remote

系列: CGI abuses

已發布: 2019/2/6

已更新: 2019/5/2

相依性: php_version.nasl

風險資訊

CVSS 評分資料來源: CVE-2016-10166

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.9

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:POC/RL:OF/RC:C

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 8.8

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:P/RL:O/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2019/1/10

弱點發布日期: 2019/1/10

參考資訊

CVE: CVE-2016-10166, CVE-2019-6977, CVE-2019-9020, CVE-2019-9021, CVE-2019-9023, CVE-2019-9024

BID: 95869, 106731, 107156