PHP 7.2.x < 7.2.13 多個弱點

high Nessus Plugin ID 119766

Synopsis

遠端主機上安裝的應用程式受到多個弱點影響。

描述

根據其標題,遠端網頁伺服器上執行的 PHP 版本為 7.2.13 之前的 7.2.x 版。因此受到多個弱點影響:- imap_open 函式中有一個任意命令插入弱點,這是因為先對郵箱名稱使用了不正確的篩選器,然後再將這些名稱傳送至 rsh 或 ssh 命令。經驗證的遠端攻擊者可加以惡意利用,透過傳送特製的 IMAP 伺服器名稱,在目標系統上執行任意命令。(CVE-2018-19518) - phar_parse_pharfile 函式中有堆積型過度讀取。未經驗證的遠端攻擊者可加以惡意利用,在嘗試剖析 .phar 檔案時,讀取實際資料之後已配置或未配置的記憶體。(CVE-2018-20783)

解決方案

升級為 PHP 7.2.13 或更新版本。

另請參閱

http://php.net/ChangeLog-7.php#7.2.13

Plugin 詳細資訊

嚴重性: High

ID: 119766

檔案名稱: php_7_2_13.nasl

版本: 1.9

類型: remote

系列: CGI abuses

已發布: 2018/12/19

已更新: 2022/5/26

組態: 啟用徹底檢查

風險資訊

VPR

風險因素: High

分數: 8.4

CVSS v2

風險因素: High

基本分數: 8.5

時間分數: 7

媒介: AV:N/AC:M/Au:S/C:C/I:C/A:C

時間媒介: E:F/RL:OF/RC:C

CVSS 評分資料來源: CVE-2018-19518

CVSS v3

風險因素: High

基本分數: 7.5

時間分數: 7

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

時間媒介: E:F/RL:O/RC:C

CVSS 評分資料來源: CVE-2018-20783

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2018/12/6

弱點發布日期: 2018/11/14

惡意利用途徑

Metasploit (php imap_open Remote Code Execution)

參考資訊

CVE: CVE-2018-19518, CVE-2018-20783

BID: 106018, 107121