Squid 3.x < 3.5.18 / 4.x < 4.0.10 多個拒絕服務弱點 (SQUID-2016:9)

high Nessus Plugin ID 119723

Synopsis

遠端 Proxy 伺服器受到多個拒絕服務弱點影響。

描述

根據其標題顯示,遠端主機上執行的 Squid 版本為 3.5.18 之前的 3.x 版或 4.0.10 之前的 4.x 版。因此受到 ESI 回應處理元件中多個拒絕服務 (DoS) 弱點影響,這是因為不正確的指標處理和參照計數所致。控制伺服器的遠端攻擊者可惡意利用此問題,透過特製的 ESI 回應對存取 Squid 服務的所有用戶端造成拒絕服務。請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級版本至 Squid 3.5.18、4.0.10 或更新版本。或者,套用供應商提供的修補程式。

另請參閱

http://www.squid-cache.org/Advisories/SQUID-2016_9.txt

Plugin 詳細資訊

嚴重性: High

ID: 119723

檔案名稱: squid_2016_9.nasl

版本: 1.2

類型: remote

系列: Firewalls

已發布: 2018/12/17

已更新: 2019/10/31

組態: 啟用 Paranoid 模式

風險資訊

VPR

風險因素: Low

分數: 3.6

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 3.7

媒介: AV:N/AC:L/Au:N/C:N/I:N/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2016-4555

CVSS v3

風險因素: High

基本分數: 7.5

時間分數: 6.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:squid-cache:squid

必要的 KB 項目: installed_sw/Squid, Settings/ParanoidReport

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2016/5/6

弱點發布日期: 2016/5/6

參考資訊

CVE: CVE-2016-4555, CVE-2016-4556