Apache Struts 2.x < 2.3.16.1 Multiple Vulnerabilities (S2-020)

high Nessus Plugin ID 117393

Synopsis

遠端主機上執行的 Web 應用程式使用受多個弱點影響的 Java 架構。

描述

遠端主機上執行的 Apache Struts 版本是比 2.3.16.1 舊的 2.x 版。因此會受到多個弱點影響,包括拒絕服務 (DoS) 弱點和 ClassLoader 操控缺陷。請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 Apache Struts 2.3.16.1 版或更新版本

另請參閱

http://www.nessus.org/u?2926fce9

http://www.nessus.org/u?e39cc37e

Plugin 詳細資訊

嚴重性: High

ID: 117393

檔案名稱: struts_2_3_16_1.nasl

版本: 1.13

類型: combined

代理程式: windows, macosx, unix

系列: Misc.

已發布: 2018/9/10

已更新: 2022/4/11

組態: 啟用徹底檢查

支持的傳感器: Frictionless Assessment Agent, Nessus Agent

風險資訊

VPR

風險因素: Low

分數: 2.9

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 6.2

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:F/RL:OF/RC:C

CVSS 評分資料來源: CVE-2014-0050

CVSS v3

風險因素: High

基本分數: 7.3

時間分數: 6.8

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

時間媒介: E:F/RL:O/RC:C

弱點資訊

CPE: cpe:/a:apache:struts

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2014/3/1

弱點發布日期: 2014/3/1

惡意利用途徑

Core Impact

Metasploit (Apache Struts ClassLoader Manipulation Remote Code Execution)

參考資訊

CVE: CVE-2014-0050, CVE-2014-0094

BID: 65400, 65999