Apache Struts 2.x < 2.3.15.3 Broken Access Control Vulnerability (S2-018)

medium Nessus Plugin ID 117391

Synopsis

遠端主機上執行的 Web 應用程式使用受無效存取控制弱點影響的 Java 架構。

描述

遠端主機上執行的 Apache Struts 版本是比 2.3.15.3 舊的 2.x 版。因此會受可用來繞過安全性限制的無效存取控制弱點影響。請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 Apache Struts 2.3.15.3 版或更新版本,或遵照供應商指示停用 DMI。

另請參閱

https://cwiki.apache.org/confluence/display/WW/S2-018

Plugin 詳細資訊

嚴重性: Medium

ID: 117391

檔案名稱: struts_2_3_15_3.nasl

版本: 1.10

類型: combined

代理程式: windows, macosx, unix

系列: Misc.

已發布: 2018/9/10

已更新: 2022/4/11

組態: 啟用徹底檢查

支持的傳感器: Frictionless Assessment Agent, Nessus Agent

風險資訊

VPR

風險因素: Low

分數: 2.5

CVSS v2

風險因素: Medium

基本分數: 5.8

時間分數: 4.3

媒介: AV:N/AC:M/Au:N/C:P/I:P/A:N

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2013-4310

CVSS v3

風險因素: Medium

基本分數: 6.5

時間分數: 5.7

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:apache:struts

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2013/9/6

弱點發布日期: 2013/9/6

參考資訊

CVE: CVE-2013-4310

BID: 62584