Apache Struts 2.0.x < 2.0.12 Multiple Vulnerabilities (S2-003) (S2-004)

critical Nessus Plugin ID 117390

Synopsis

遠端主機上執行的 Web 應用程式使用受多個弱點影響的 Java 架構。

描述

遠端主機上執行的 Apache Struts 版本是比 2.0.12 舊的 2.0.x 版。因此,可能會因為 ParameterInterceptor 類別錯誤驗證使用者提供,而受到 OGNL 運算式執行弱點影響。此外,應用程式也會受可能的目錄周遊弱點影響。請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 Apache Struts 2.0.12 版或更新版本

另請參閱

http://www.nessus.org/u?76f5095d

Plugin 詳細資訊

嚴重性: Critical

ID: 117390

檔案名稱: struts_2_0_12.nasl

版本: 1.6

類型: combined

代理程式: windows, macosx, unix

系列: Misc.

已發布: 2018/9/10

已更新: 2022/4/11

組態: 啟用徹底檢查

支持的傳感器: Nessus Agent

風險資訊

CVSS 評分論據: Ognl execution

CVSS v2

風險因素: Critical

基本分數: 10

媒介: AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS 評分資料來源: manual

CVSS v3

風險因素: Critical

基本分數: 9.8

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

弱點資訊

CPE: cpe:/a:apache:struts

修補程式發佈日期: 2007/6/22

弱點發布日期: 2008/6/22