Apache Struts 2.x < 2.2.3 Multiple XSS (S2-006)

medium Nessus Plugin ID 117388

Synopsis

遠端主機上執行的 Web 應用程式使用受多個跨網站指令碼弱點影響的 Java 架構。

描述

遠端主機上執行的 Apache Struts 版本是比 2.2.3 舊的 2.x 版。因此,可能會因為錯誤驗證動作名稱,而受多個跨網站指令碼 (XSS) 弱點影響。請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 Apache Struts 2.2.3 版或更新版本

另請參閱

https://cwiki.apache.org/confluence/display/WW/S2-006

Plugin 詳細資訊

嚴重性: Medium

ID: 117388

檔案名稱: struts_2_2_3.nasl

版本: 1.8

類型: combined

代理程式: windows, macosx, unix

系列: Misc.

已發布: 2018/9/10

已更新: 2022/4/11

組態: 啟用徹底檢查

支持的傳感器: Nessus Agent

風險資訊

CVSS 評分論據: Cross-site scripting

VPR

風險因素: Low

分數: 2.2

CVSS v2

風險因素: Medium

基本分數: 4.3

時間分數: 3.6

媒介: AV:N/AC:M/Au:N/C:N/I:P/A:N

時間媒介: E:F/RL:OF/RC:C

CVSS 評分資料來源: manual

CVSS v3

風險因素: Medium

基本分數: 4.3

時間分數: 3.9

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N

時間媒介: E:P/RL:O/RC:C

弱點資訊

CPE: cpe:/a:apache:struts

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2011/5/9

弱點發布日期: 2011/5/9

參考資訊

CVE: CVE-2011-1772

BID: 47784